OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Medium
  • Priority Very Low
  • Reported Version openwrt-19.07
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Federico Capoano - 21.04.2021

FS#3748 - MAC address of eth0 and eth1 are swapped on ath79 on Nanostation M models

Tested on Nanostation M2, OpenWRT 19.07.

The problem does not occur on ar71xx and for this reason we are continuing to use ar71xx for this model, but would be nice to fix this before OpenWRT 21 if possible.

Steps to reproduce:

- note down the mac address of eth0 and eth1 of stock firmware
- flash the ath79 image of OpenWRT 19.07

Expected result:

- mac addresses of eth0 and eth1 are consistent with stock firmware

Actual result:

- mac addresses of eth0 and eth1 are swapped, that is: eth1 has the mac address of eth0 and eth0 has the mac address of eth 1

This causes problems to any system which relies on the mac address of one of these interfaces to recognize the device.

More information in this forum thread: https://forum.openwrt.org/t/mac-address-changed-after-sysupgrade-from-backfire-nanostation-m2/93530/5

Please let me know if you can confirm the issue and are willing to accept a patch.

Federico Capoano commented on 16.07.2021 18:49

I just wanted to send an update here: I found the same issue on the Ubiquiti AirRouter.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing