OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity High
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Anthony - 05.04.2021
Last edited by Baptiste Jonglez - 27.04.2021

FS#3724 - GL-MT1300 can not use 2.4Ghz wifi

Device: ramips/mt7621/GL-MT1300
OpenWrt lastest trunk version, with luci installed.

In wireless, when N mode is selected, there is no 2.4G/5G switching option and cannot be set to 2.4G.

After modifying the /etc/config/wireless file, the following errors are reported in the system log.

Sun Apr 4 21:49:15 2021 daemon.notice hostapd: Configuration file: /var/run/hostapd-phy0.conf (phy wlan0)
Sun Apr 4 21:49:15 2021 daemon.err hostapd: Interface name wlan0 already in use
Sun Apr 4 21:49:15 2021 daemon.notice netifd: radio0 (10727): Command failed: Invalid argument
Sun Apr 4 21:49:15 2021 daemon.notice netifd: radio0 (10727): Device setup failed: HOSTAPD_START_FAILED
Sun Apr 4 21:49:15 2021 daemon.notice netifd: radio0 (10816): WARNING: Variable ‘data’ does not exist or is not an array/object

Closed by  Baptiste Jonglez
27.04.2021 09:16
Reason for closing:  Different project
Additional comments about closing:  

Luci bug

easyteacher commented on 05.04.2021 11:25

There is a solution, just set wireless from uci commands.

uci set wireless.radio0.disabled='0'
uci set wireless.radio0.hwmode='11g'
uci set wireless.radio0.htmode='HT20'
uci set wireless.radio0.cell_density='0'
uci set wireless.radio0.country='US'
uci set wireless.radio0.channel='3'
uci set wireless.radio1.hwmode='11a'
uci set wireless.radio1.htmode='VHT80'
uci set wireless.radio1.disabled='0'
uci set wireless.radio1.cell_density='0'
uci set wireless.radio1.country='US'
uci set wireless.radio1.channel='36'
uci commit wireless
wifi

Anthony commented on 05.04.2021 14:20

I tried it, and it worked. So the problem is that there's something wrong with Luci, isn't it?

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing