OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Kernel
  • Assigned To No-one
  • Operating System All
  • Severity Critical
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by pesa1234 - 01.04.2021

FS#3717 - WRT1900ACS LAN Switch speed on kernel 5.4

Dear, I ‘ve found an issue with DSA and kernel 5.4.
I’m on 21.02 SNAPSHOT.
My upload speed on WAN is only 10 mbps when a device with LAN connection is linked to 10mbps.
When a device 100mbps is connected to switch all speed is 100mbps not 1 gbps
It seems that the upload speed follow the lowest lan speed...

First test is with 10mbps connection on LAN3. –> Test was done from LAN1 to router.
Second test is with a LAN2 device conneted with 100mbps. –> Test was done from LAN1 to router

PS C:\Users\Andrea\Downloads\iperf-3.1.3-win64> .\iperf3.exe -c 192.168.181.1
Connecting to host 192.168.181.1, port 5201
[  4] local 192.168.181.159 port 50593 connected to 192.168.181.1 port 5201
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-1.01   sec   384 KBytes  3.12 Mbits/sec
[  4]   1.01-2.01   sec   640 KBytes  5.26 Mbits/sec
[  4]   2.01-3.01   sec  1.12 MBytes  9.35 Mbits/sec
[  4]   3.01-4.01   sec  1.12 MBytes  9.52 Mbits/sec
[  4]   4.01-5.01   sec  1.12 MBytes  9.41 Mbits/sec
[  4]   5.01-6.00   sec  1.12 MBytes  9.50 Mbits/sec
[  4]   6.00-7.00   sec  1.12 MBytes  9.46 Mbits/sec
[  4]   7.00-8.00   sec  1.12 MBytes  9.41 Mbits/sec
[  4]   8.00-9.01   sec  1.12 MBytes  9.40 Mbits/sec
[  4]   9.01-10.01  sec  1.12 MBytes  9.44 Mbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-10.01  sec  10.0 MBytes  8.38 Mbits/sec                  sender
[  4]   0.00-10.01  sec  9.81 MBytes  8.23 Mbits/sec                  receiver

iperf Done.
PS C:\Users\Andrea\Downloads\iperf-3.1.3-win64> .\iperf3.exe -c 192.168.181.1 -R
Connecting to host 192.168.181.1, port 5201
Reverse mode, remote host 192.168.181.1 is sending
[  4] local 192.168.181.159 port 50611 connected to 192.168.181.1 port 5201
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-1.00   sec  95.6 MBytes   802 Mbits/sec
[  4]   1.00-2.00   sec  97.9 MBytes   821 Mbits/sec
[  4]   2.00-3.00   sec   101 MBytes   847 Mbits/sec
[  4]   3.00-4.00   sec   101 MBytes   850 Mbits/sec
[  4]   4.00-5.00   sec   105 MBytes   884 Mbits/sec
[  4]   5.00-6.00   sec  92.3 MBytes   774 Mbits/sec
[  4]   6.00-7.00   sec   105 MBytes   877 Mbits/sec
[  4]   7.00-8.00   sec   102 MBytes   849 Mbits/sec
[  4]   8.00-9.00   sec  99.4 MBytes   836 Mbits/sec
[  4]   9.00-10.00  sec   107 MBytes   894 Mbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bandwidth       Retr
[  4]   0.00-10.00  sec  1006 MBytes   844 Mbits/sec   23             sender
[  4]   0.00-10.00  sec  1006 MBytes   844 Mbits/sec                  receiver

This new test is with latest 19.07 (previous kernel no dsa)

BusyBox v1.30.1 () built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt 19.07-SNAPSHOT, r11328-81266d9001
 -----------------------------------------------------
root@WRT1900ACS:~# iperf3 -s
-----------------------------------------------------------
Server listening on 5201
-----------------------------------------------------------
Accepted connection from 192.168.181.159, port 48454
[  5] local 192.168.181.1 port 5201 connected to 192.168.181.159 port 48456
[ ID] Interval           Transfer     Bitrate
[  5]   0.00-1.00   sec   108 MBytes   905 Mbits/sec                  
[  5]   1.00-2.00   sec   109 MBytes   915 Mbits/sec                  
[  5]   2.00-3.00   sec   109 MBytes   914 Mbits/sec                  
[  5]   3.00-4.00   sec   107 MBytes   900 Mbits/sec                  
[  5]   4.00-5.00   sec   108 MBytes   907 Mbits/sec                  
[  5]   5.00-6.00   sec   109 MBytes   912 Mbits/sec                  
[  5]   6.00-7.00   sec   107 MBytes   896 Mbits/sec                  
[  5]   7.00-8.00   sec   109 MBytes   917 Mbits/sec                  
[  5]   8.00-9.00   sec   108 MBytes   905 Mbits/sec                  
[  5]   9.00-10.00  sec   108 MBytes   903 Mbits/sec                  
[  5]  10.00-10.00  sec   293 KBytes   892 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate
[  5]   0.00-10.00  sec  1.06 GBytes   907 Mbits/sec 

I also noticed that with the latest version the switch LEDs flash all together and not only follow where there is communication, but I don’t think this is a problem.

Is this speed issue a bug or I do something wrong? I don’t make any changes to network config from standard. Only changed IP from 192.168.1.1 to 192.168.181.1.

pesa1234 commented on 04.04.2021 09:08

Nobody?

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing