OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Kernel
  • Assigned To No-one
  • Operating System All
  • Severity Critical
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Vladdrako - 01.04.2021
Last edited by Ted Hess - 11.05.2021

FS#3716 - mt7621: packet loss with connected USB devices on kernel 5.10

Device: Xiaomi Mi Router 3G.
On kernel 5.10 when I’m trying to use USB-HDD ping is going high. All network lag as hell. No errors in logs. I can’t test other devices like modems etc.
My devices:

root@MI-R3G:~# lsusb
Bus 001 Device 004: ID 152d:0579 JMICRON JMS579
Bus 001 Device 006: ID 0d9f:0004 POWERCOM Co.,LTD HID UPS Battery
Bus 002 Device 001: ID 1d6b:0003 Linux 5.4.108 xhci-hcd xHCI Host Controller
Bus 001 Device 003: ID 152d:0579 JMICRON JMS579
Bus 001 Device 005: ID 8564:1000 JetFlash Mass Storage Device
Bus 001 Device 002: ID 05e3:0610 GenesysLogic USB2.0 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux 5.4.108 xhci-hcd xHCI Host Controller
root@MI-R3G:~# lsusb -v -t
/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=xhci-mtk/1p, 5000M
    ID 1d6b:0003
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=xhci-mtk/2p, 480M
    ID 1d6b:0002
    |__ Port 1: Dev 2, If 0, Class=, Driver=hub/4p, 480M
        ID 05e3:0610
        |__ Port 1: Dev 3, If 0, Class=, Driver=usb-storage, 480M
            ID 152d:0579
        |__ Port 2: Dev 4, If 0, Class=, Driver=usb-storage, 480M
            ID 152d:0579
        |__ Port 3: Dev 5, If 0, Class=, Driver=usb-storage, 480M
            ID 8564:1000
        |__ Port 4: Dev 6, If 0, Class=, Driver=usbfs, 1.5M
            ID 0d9f:0004
Closed by  Ted Hess
11.05.2021 10:43
Reason for closing:  Not a bug
Vladdrako commented on 01.04.2021 06:07

I attached lsusb output from 5.4, but the same on 5.10 ;) 5.10 is unusable due to this bug.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing