OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Base system
  • Assigned To
    Hans Dedecker
  • Operating System All
  • Severity Medium
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by LGA1150 - 19.03.2021
Last edited by Hans Dedecker - 30.10.2021

FS#3690 - 6in4 interfaces creation sometimes stuck in an infinite loop

Router: Linksys WRT1900AC v2
OpenWrt version: SNAPSHOT r16134-c6652a7c94
netifd version: 2021-01-09-c00c8335-1

I have set up multiple 6in4 interfaces for testing, but sometimes some interface won’t come up.
The system log is flooded with errors like these:

Fri Mar 19 20:32:58 2021 daemon.notice netifd: Interface 'wan6_4' is setting up now
Fri Mar 19 20:32:58 2021 daemon.notice netifd: wan6_4 (13717): Command failed: Unknown error
Fri Mar 19 20:32:58 2021 daemon.notice netifd: Interface 'wan6_4' is now down
Fri Mar 19 20:32:58 2021 daemon.notice netifd: Interface 'wan6_4' is setting up now
Fri Mar 19 20:32:58 2021 daemon.notice netifd: wan6_4 (13770): Command failed: Unknown error
Fri Mar 19 20:32:58 2021 daemon.notice netifd: Interface 'wan6_4' is now down
Fri Mar 19 20:32:58 2021 daemon.notice netifd: Interface 'wan6_4' is setting up now
Fri Mar 19 20:32:58 2021 daemon.notice netifd: wan6_4 (13794): Command failed: Unknown error
Fri Mar 19 20:32:58 2021 daemon.notice netifd: Interface 'wan6_4' is now down
Fri Mar 19 20:32:58 2021 daemon.notice netifd: Interface 'wan6_4' is setting up now
Fri Mar 19 20:32:58 2021 daemon.notice netifd: wan6_4 (13847): Command failed: Unknown error
Fri Mar 19 20:32:58 2021 daemon.notice netifd: Interface 'wan6_4' is now down
Fri Mar 19 20:32:58 2021 daemon.notice netifd: Interface 'wan6_4' is setting up now
Fri Mar 19 20:32:58 2021 daemon.notice netifd: wan6_4 (13871): Command failed: Unknown error
Fri Mar 19 20:32:58 2021 daemon.notice netifd: Interface 'wan6_4' is now down

And it also hogs CPU.

An workaround is manually remove the tunnel with iproute2, then restart the interface:

ip tun del 6in4-wan6_4
ifup wan6_4
Closed by  Hans Dedecker
30.10.2021 19:18
Reason for closing:  Fixed
Additional comments about closing:  

Fixed in commit https://git.op enwrt.org/?p=project/netifd.git;a=commit ;h=8f82742ca4f47f459284f3a07323d04da72ea 5f6

LGA1150 commented on 29.05.2021 18:08

Update: It seems only kernel 5.10 has this issue.

Ansuel commented on 18.07.2021 17:03

Can also confirm... I have this problem currently with dsa and he-tunnel (that i think is 6in4 ?)

Project Manager
Felix Fietkau commented on 18.07.2021 18:08

Can you please post a /etc/config/network that reproduces this?

Ansuel commented on 18.07.2021 18:10

On my side it's really the basic network config with just lan bridge and the tunnel setup. nothing special at all. The problem is that thinks works for a while and then chase to work... I currently have a broken condition so if you have some command or you need some data, I can give you them very quickly.

Ansuel commented on 18.07.2021 18:12

My current network config

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd49:5134:465f::/48'
	option packet_steering '1'

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.2.1'
	option stp '1'
	option netmask '255.255.255.0'
	option ifname 'lan1 lan2 lan3 lan4 tap_ext-br tap_rome-br tap_taranto-br'

config interface 'guest'
	option proto 'static'
	option netmask '255.255.255.0'
	option _orig_ifname 'wlan1-1'
	option _orig_bridge 'false'
	option type 'bridge'
	option ipaddr '192.168.20.1'
	option ip6assign '64'
	option ip6hint '0002'

config interface 'wan'
	option ifname 'wan'
	option proto 'pppoe'
	option ipv6 'auto'
	option username 'asda'
	option password 'as'

config interface 'hetunnel'
	option proto '6in4'
	option peeraddr 'REDACTED'
	option ip6addr 'REDACTED/64'
	option tunnelid '550591'
	option username 'REDACTED'
	option password 'REDACTED'
	list ip6prefix 'REDACTED::/48'

config interface 'modem'
	option proto 'static'
	option ifname 'wan'
	option ipaddr '192.168.1.5'
	option netmask '255.255.255.0'

config route
	option interface 'lan'
	option target '192.168.3.0/24'
	option netmask '255.255.255.0'
	option gateway '192.168.2.254'
Ansuel commented on 24.07.2021 17:02

Any news on this?

Ansuel commented on 27.07.2021 13:05

I tried updating iproute2 to the latest version 5.13 and now it doesn't work from the boot...

Ansuel commented on 02.08.2021 11:42

@LGA1150 Can you test if this fix the problem?
https://github.com/openwrt/openwrt/pull/4418

(notice the tunnel is not removed on interface teardown (or interface restart))

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing