Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

FS#3639 - Repeated failure of wireless interfaces, seemingly related to IGMP Snooping #8676

Open
openwrt-bot opened this issue Feb 24, 2021 · 2 comments
Labels

Comments

@openwrt-bot
Copy link

nohspamjose:

Supply the following if possible:

Model: Linksys WRT3200ACM
Architecture: ARMv7 Processor rev 1 (v7l)
Firmware Version: OpenWrt 19.07.7 r11306-c4a6851c72 / LuCI openwrt-19.07 branch git-21.054.03371-3b137b5
Kernel Version: 4.14.221

In the last four to six days the wireless on my network kept failing (particularly overnight - but that may be less to do with time of day and more to do with lease expiry??). I searched and found that someone else resolved this back in around 2018 by enabling IGMP Snooping and then rebooting their router (https://forum.openwrt.org/t/wifi-up-device-connected-but-no-internet/) - That worked for me but only temporarily. This morning, even though (on LuCI and via SSH) I can see IGMP Snooping is still enabled (LAN interface), the same problem occurred - all the wireless devices can connect to the router but not the Internet. For the moment, rebooting the router fixed it but clearly that's not a realistic solution.

I have marked this high severity because:

  • It looks like a regression
  • My kids can't access school via their iPads and are getting marked absent! (like many/most, we're in lockdown)

/etc/config/network reads:

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fddf:17c3:6271::/48'

config interface 'lan'
option type 'bridge'
option ifname 'eth0.1'
option proto 'static'
option netmask '255.255.255.0'
option ip6assign '60'
option broadcast '192.168.7.255'
option ipaddr '192.168.7.1'
option gateway '****' <- my WAN static IP
list dns '1.1.1.1'
option igmp_snooping '1' <- I set this, which seemed to resolve it, but only for a bit

config interface 'wan'
option ifname 'eth1.2'
option proto 'pppoe'
option password ''
option ipv6 'auto'
option username '
'

config interface 'wan6'
option ifname 'eth1.2'
option proto 'dhcpv6'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '0 1 2 3 5t'

config switch_vlan
option device 'switch0'
option vlan '2'
option ports '4 6t'

config interface 'wwan'
option proto 'dhcp'

@openwrt-bot
Copy link
Author

nohspamjose:

My Wireless config may be useful too:

config wifi-device 'radio0'
option type 'mac80211'
option channel '36'
option hwmode '11a'
option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
option htmode 'VHT80'
option txpower '23'

config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option key '****'
option ssid 'PQR'
option encryption 'psk2'

config wifi-device 'radio1'
option type 'mac80211'
option hwmode '11g'
option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
option txpower '20'
option htmode 'HT40'
option channel '11'

config wifi-device 'radio2'
option type 'mac80211'
option path 'platform/soc/soc:internal-regs/f10d8000.sdhci/mmc_host/mmc0/mmc0:0001/mmc0:0001:1'
option hwmode '11g'
option htmode 'HT20'
option channel 'auto'

config wifi-iface 'wifinet1'
option ssid 'ABC'
option encryption 'psk2'
option device 'radio1'
option mode 'ap'
option network 'lan'
option key '****'

@openwrt-bot
Copy link
Author

nohspamjose:

Will no one THINK OF THE CHILDREN!!!!

;o)

[In other news, another reboot - along with setting the option igmp_snooping '1' seems to have fixed it and be stable for the last couple of days (fingers crossed)]

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
Projects
None yet
Development

No branches or pull requests

1 participant