OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by timkgh - 16.02.2021

FS#3625 - NL80211_ATTR_STA_VLAN errors

Devices: Netgear R7800, UniFi AP AC Lite

OpenWrt SNAPSHOT, r15805-1da945b760
OpenWrt SNAPSHOT, r15806-c68d527991

kmod-cfg80211 - 5.4.98+5.10-rc6-1-1
kmod-mac80211 - 5.4.98+5.10-rc6-1-1

logread shows these frequent error messages for various wifi clients:

Mon Feb 15 20:08:47 2021 daemon.err hostapd: nl80211: NL80211_ATTR_STA_VLAN (addr=xx:xx:xx:xx:xx:xx ifname=wlan0 vlan_id=0) failed: -2 (No such file or directory)


timkgh commented on 16.02.2021 16:19

This may have something to do 802.11r which I have enabled and it used to work.

I also see this in the logs:

Mon Feb 15 20:08:45 2021 daemon.err hostapd: nl80211: kernel reports: key addition failed

jon-wrennall commented on 16.02.2021 17:42

I get exactly the same issue on DAP-2695 with OpenWrt SNAPSHOT r15744-68073e2d46

Eneas U de Queiroz commented on 16.02.2021 23:34

I got a WRT3200ACM (mvebu with mwlwifi), running r15553-0988e03f0e, and have the same issue. If I switch ft_over_ds '0', then the NL80211_ATTR_STA_VLAN messages apparently go away, while 'key addition failed' ones remain.

timkgh commented on 17.02.2021 16:53

Exactly the same as the post above, "FT over the Air" makes NL80211_ATTR_STA_VLAN errors go away but 'key addition failed' errors remain and my clients do not seem to FT anymore.

jon-wrennall commented on 18.02.2021 10:18

I need to validate this but I think it is only happening on apple iPhone devices/similar?
and still happening on latest build of master ( r15838-d2d32dcd5f )

Eneas U de Queiroz commented on 18.02.2021 13:32

It does not appear to happen with my Windows NB here [Intel(R) Wireless-AC 9462], but it does with iPhone and other Apple devices. I've tested this with 21.02- r15818-c6319239d8 now.

timkgh commented on 18.02.2021 18:32

Could it be because mainly iOS devices are actually trying to roam/use FT?

Eneas U de Queiroz commented on 18.02.2021 21:33

Possibly. I can't figure out if my Windows machine even tried to do FT or not.

rbpp commented on 19.02.2021 10:38

I also have the same error messages for maybe a year already, on all master versions that I used (upgrading on a weekly or so basis), on all my 801.11r enabled devices (R7800, C2600, C7).

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing