Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

FS#3583 - TPLink RE450 Falis getting IP on 5Ghz radio #8613

Open
openwrt-bot opened this issue Jan 20, 2021 · 2 comments
Open

FS#3583 - TPLink RE450 Falis getting IP on 5Ghz radio #8613

openwrt-bot opened this issue Jan 20, 2021 · 2 comments
Labels

Comments

@openwrt-bot
Copy link

wojciechczyz:

Supply the following if possible:

  • Device problem occurs on
    RE450 set up as dumb Access Point
    Main router is WRT1900ACS also using OpenWRT 19.07.6
    Main router is DHCP server.

  • Software versions of OpenWrt/LEDE release, packages, etc.
    OpenWrt 19.07.6 r11278-8055e38794

  • Steps to reproduce

Ethernet, Wifi 0 and Wifi 1 are all bridged as LAN.

When I connect to 2.4Ghz WIfi, devices connect and get IP and access to the internet.
When I connect to 5Ghz wifi, devices cannot obtain IP and disconnect.
On conecting Mac I see message that it failed to obtain IP

Network:
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fd7c:fc53:55ff::/48'

config interface 'lan'
option type 'bridge'
option ifname 'eth0'
option proto 'static'
option ipaddr '192.168.1.2'
option gateway '192.168.1.1'
list dns '192.168.1.1'
option netmask '255.255.255.0'

Wireless:
config wifi-device 'radio0'
option type 'mac80211'
option hwmode '11a'
option path 'pci0000:00/0000:00:00.0'
option htmode 'VHT80'
option channel 'auto'
option country 'ES'

config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option key 'pass'
option encryption 'psk2'
option ssid 'AP5G'
option disassoc_low_ack '0'

config wifi-device 'radio1'
option type 'mac80211'
option hwmode '11g'
option path 'platform/ahb/18100000.wmac'
option channel 'auto'
option noscan '1'
option htmode 'HT40'
option country 'ES'

config wifi-iface 'default_radio1'
option device 'radio1'
option network 'lan'
option mode 'ap'
option key 'pass'
option encryption 'psk2'
option ssid 'AP'
option disassoc_low_ack '0'

DHCP:

config dnsmasq
option domainneeded '1'
option boguspriv '1'
option filterwin2k '0'
option localise_queries '1'
option rebind_protection '1'
option rebind_localhost '1'
option local '/lan/'
option domain 'lan'
option expandhosts '1'
option nonegcache '0'
option authoritative '1'
option readethers '1'
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.auto'
option nonwildcard '1'
option localservice '1'

config dhcp 'lan'
option interface 'lan'
option ignore '1'

config dhcp 'wan'
option interface 'wan'
option ignore '1'

config odhcpd 'odhcpd'
option maindhcp '0'
option leasefile '/tmp/hosts/odhcpd'
option leasetrigger '/usr/sbin/odhcpd-update'
option loglevel '4'

@openwrt-bot
Copy link
Author

abcydybcy:

I have the exact same problem with WRT1900ACS.
Restarting networking and odhcp services doesn't fix it, neither does a wifi restart via Luci.
Please note that the wifi AP 'IOT' is configured on an external USB wifi card.

Linux OpenWrt 4.14.215 #0 SMP Tue Jan 19 13:10:02 2021 armv7l GNU/Linux
OpenWrt 19.07.6 r11278-8055e38794 / LuCI openwrt-19.07 branch git-21.029.68283-bf8b0bb
Using odhcpd (dnsmasq removed).

/etc/config/network

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fd9a:e428:e416::/48'

config interface 'lan'
option type 'bridge'
option ifname 'eth0.1'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
list dns '192.168.1.1'
option ip6assign '64'
option ip6hint '1'

config interface 'wan'
option ifname 'eth1.35'
option proto 'pppoe'
option password ''
option username ''
option peerdns '0'
option ipv6 'auto'

config interface 'wan6'
option ifname 'pppoe-wan'
option proto '6in4'
option username 'f0ff'
option peeraddr '216.66.80.162'
list ip6prefix ''
option ip6addr ''
option tunnelid ''
option password ''

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option vid '1'
option ports '1 2 3 5t'

config switch_vlan
option device 'switch0'
option vlan '2'
option ports '4 6t'
option vid '2'

config switch_vlan
option device 'switch0'
option vlan '3'
option vid '35'
option ports '4t 6t'

config interface 'guest'
option proto 'static'
option netmask '255.255.255.0'
option ipaddr '192.168.2.1'
option type 'bridge'
option ifname 'eth0.3'
list dns '192.168.2.1'
option ip6assign '64'
option ip6ifaceid '::3'
option ip6hint '2'

config switch_vlan
option device 'switch0'
option vlan '4'
option ports '5t'
option vid '3'

config switch_vlan
option device 'switch0'
option vlan '5'
option vid '4'
option ports '0 5t'

config interface 'iot'
option proto 'static'
option type 'bridge'
option ipaddr '192.168.3.1'
option netmask '255.255.255.0'
list dns '192.168.3.1'
option ifname 'eth0.4'
option ip6assign '64'
option ip6hint '3'

/etc/config/dhcp
config dhcp 'lan'
option interface 'lan'
option start '100'
option limit '150'
option leasetime '12h'
option dhcpv6 'server'
option ra 'server'
option ra_management '1'
option dhcpv4 'server'
option force '1'

config dhcp 'wan'
option interface 'wan'
option ignore '1'

config odhcpd 'odhcpd'
option leasefile '/tmp/hosts/odhcpd'
option loglevel '4'
option maindhcp '1'
option leasetrigger '/usr/lib/unbound/odhcpd.sh'

config dhcp 'guest'
option leasetime '12h'
option limit '150'
option interface 'guest'
option start '10'
option ra 'server'
option dhcpv6 'server'
option ra_management '1'

config dhcp 'iot'
option start '100'
option leasetime '12h'
option limit '150'
option interface 'iot'
option ra 'server'
option dhcpv6 'server'
option ra_management '1'

/etc/config/wireless

config wifi-device 'radio0'
option type 'mac80211'
option hwmode '11a'
option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
option legacy_rates '0'
option distance '10'
option htmode 'VHT80'
option country 'US'
option channel 'auto'
option txpower '20'

config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option macaddr '62:38:e0:d7:62:45'
option wpa_disable_eapol_key_retries '1'
option key ''
option ssid 'home5'
option encryption 'psk2'

config wifi-device 'radio1'
option type 'mac80211'
option hwmode '11g'
option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
option legacy_rates '0'
option txpower '20'
option country 'PL'
option htmode 'HT20'
option channel '5'

config wifi-iface 'default_radio1'
option device 'radio1'
option network 'lan'
option mode 'ap'
option macaddr '62:38:e0:d7:62:44'
option key ''
option ssid 'home'
option encryption 'psk2'

config wifi-iface 'wifinet2'
option ssid 'guest'
option encryption 'psk2'
option device 'radio1'
option mode 'ap'
option isolate '1'
option key ''
option network 'guest'

config wifi-device 'radio2'
option type 'mac80211'
option hwmode '11g'
option path 'platform/soc/soc:internal-regs/f1058000.usb/usb1/1-1/1-1:1.0'
option htmode 'HT20'
option txpower '20'
option channel '1'
option distance '14'
option country 'PL'

config wifi-iface 'default_radio2'
option device 'radio2'
option mode 'ap'
option ssid 'iot'
option encryption 'psk2'
option ieee80211w '1'
option network 'iot'
option key ''

config wifi-iface 'wifinet4'
option network 'guest'
option wpa_disable_eapol_key_retries '1'
option ssid 'guest5'
option encryption 'psk2'
option device 'radio0'
option mode 'ap'
option ieee80211w '1'
option key ''

@openwrt-bot
Copy link
Author

abcydybcy:

System log: [[https://pastebin.com/iuffNmc1|Pastebin]]

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
Projects
None yet
Development

No branches or pull requests

1 participant