OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Kernel
  • Assigned To No-one
  • Operating System All
  • Severity Very Low
  • Priority Very Low
  • Reported Version openwrt-19.07
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Rinat - 19.12.2020

FS#3524 - TP-Link Archer C7 v2, missing tp-link:green:lan* and tp-link:green:wan led controls

Hardware is TP-Link Archer C7 v2.

I’ve just upgraded to 19.07.5 using prebuilt image “openwrt-19.07.5-ath79-generic-tplink_archer-c7-v2-squashfs-sysupgrade.bin” from some version of LEDE 17, and found that it’s not possible to control LAN/WAN leds anymore. There are tp-link:green:{qss,system,usb1,usb2,wlan2g,wlan5g} leds listed in /sys/class/leds, but there are no mentions of lan1, lan2, lan3, lan4 or wan. I don’t remember which particular version of LEDE it was before. Something from 2017.

Next is just a guess. I’ve tried to bisect code, but without trying to build and run it on the hardware, and found that last time string “tp-link:green:wan” was in the source that was somehow related to Archer C7 v2 was just before 4e4ee4649553ab536225060a27fc320bf54e458c (ar71xx: drop target). In target/linux/ar71xx/files/arch/mips/ath79/mach-archer-c7.c there were two sets of leds. One, registered with mdiobus_register_board_info(), these are now missing. And another, registered with ath79_register_leds_gpio(), these are now present.

Haven’t had a chance to test various versions from bisecting on the actual hardware yet.

Project Manager
Adrian Schmutzler commented on 02.01.2021 13:48

It appears those are handled directly by the switch now, and cannot be reassigned anymore. ath79 is a completely different setup/configuration compared to ar71xx, so it has different capabilities as well.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing