OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity High
  • Priority Very Low
  • Reported Version openwrt-19.07
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by newfoundglory - 19.12.2020
Last edited by Adrian Schmutzler - 11.02.2021

FS#3522 - ath79 Image for TL-WR810N v1.1 causes soft bricked device

Flashing the TL-WR810N v1.1 (EU version) with target ath79 is known to cause soft brick. Appears to work with ar71xx target.

There is a warning about this already on the device page: https://openwrt.org/toh/tp-link/tl-wr810n

Problem detailed in forum post:

https://forum.openwrt.org/t/tp-link-tl-wr810n-v1-ath79/48267

I could not find a record of this in the bug tracker, and so I have created one.


Closed by  Adrian Schmutzler
11.02.2021 23:46
Reason for closing:  Fixed
Project Manager
Adrian Schmutzler commented on 02.01.2021 14:13

It appears that the USB power GPIO is different between ar71xx and ath79. Depending on what a wrong GPIO would do, this at least has a chance of being the root cause to the problem:

https://github.com/openwrt/openwrt/blob/openwrt-19.07/target/linux/ar71xx/files/arch/mips/ath79/mach-tl-wr810n.c#L38

I have adjusted the GPIO for ath79 in a staging branch here:
https://git.openwrt.org/?p=openwrt/staging/adrian.git;a=shortlog;h=refs/heads/wr810n

Please test whether this helps with the issue.

Note that the branch is master, but you should be able to apply the same change to 19.07 easily if you do not want to test with master.

Project Manager
Adrian Schmutzler commented on 21.01.2021 22:02

Ping.

Project Manager
Adrian Schmutzler commented on 11.02.2021 23:46

Luckily a forum user was available for testing, so this is fixed in https://github.com/openwrt/openwrt/commit/6934d30cf8d95bc8652b4dcd8180d14e5e8e2417

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing