OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Medium
  • Priority Very Low
  • Reported Version openwrt-19.07
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by goodness-from-me - 17.12.2020

FS#3517 - isolate '1' is being applied to whole radio device instead of an individual wifi network

Device: Xiaomi Mi Router 3G v1
OpenWrt release: 19.07.5

This is a regression I found out after upgrading from 19.07.4 (with all configs being wiped).

Description: Having two wireless networks for one radio interface and setting

isolate '1'

for one of them actually applies it to all the networks in that interface so all wireless clients are isolated from each other.

My wireless config looks like this:

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:01.0/0000:02:00.0'
        option htmode 'VHT80'
        option channel '100'
        option legacy_rates '0'
        option country 'UA'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option wpa_disable_eapol_key_retries '1'
        option key '123123123'
        option ssid 'NETWORK1'
        option encryption 'psk2+ccmp'

config wifi-iface 'wifinet2'
        option network 'lan'
        option wpa_disable_eapol_key_retries '1'
        option ssid 'NETWORK2'
        option encryption 'psk2+ccmp'
        option device 'radio1'
        option mode 'ap'
        option isolate '1'
        option key '123123123'

Note that isolation is only set to the “NETWORK2”, but actually it is applied to the “NETWORK1” as well and my devices can’t reach each other being in “NETWORK1”.

Steps to reproduce:

1. Assuming you have 19.07.5 with a clean configuration.
2. Set up two wireless networks for the same radio device, call one “NETWORK1” and second - “NETWORK2”.
3. For “NETWORK2” add “option isolate ‘1’” to the wireless config.
4. Apply the settings.
5. Connect two devices to the “NETWORK1”.
6. Giving device one, try to ping device 2, having both devices connected to “NETWORK1”.

Actual result: device 2 can’t be reached from device 1 in the “NETWORK1”.
Expected result: device 2 can be reached from device 1 in the “NETWORK1”.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing