Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

FS#3517 - isolate '1' is being applied to whole radio device instead of an individual wifi network #8631

Closed
openwrt-bot opened this issue Dec 17, 2020 · 0 comments
Labels

Comments

@openwrt-bot
Copy link

goodness-from-me:

Device: Xiaomi Mi Router 3G v1
OpenWrt release: 19.07.5

//This is a regression I found out after upgrading from 19.07.4 (with all configs being wiped).//

Description:
Having two wireless networks for one radio interface and setting isolate '1' for one of them actually applies it to all the networks in that interface so all wireless clients are isolated from each other.

My wireless config looks like this:
config wifi-device 'radio1'
option type 'mac80211'
option hwmode '11a'
option path 'pci0000:00/0000:00:01.0/0000:02:00.0'
option htmode 'VHT80'
option channel '100'
option legacy_rates '0'
option country 'UA'

config wifi-iface 'default_radio1'
option device 'radio1'
option network 'lan'
option mode 'ap'
option wpa_disable_eapol_key_retries '1'
option key '123123123'
option ssid 'NETWORK1'
option encryption 'psk2+ccmp'

config wifi-iface 'wifinet2'
option network 'lan'
option wpa_disable_eapol_key_retries '1'
option ssid 'NETWORK2'
option encryption 'psk2+ccmp'
option device 'radio1'
option mode 'ap'
option isolate '1'
option key '123123123'

Note that isolation is only set to the "NETWORK2", but actually it is applied to the "NETWORK1" as well and my devices can't reach each other being in "NETWORK1".

Steps to reproduce:

  1. Assuming you have 19.07.5 with a clean configuration.
  2. Set up two wireless networks for the same radio device, call one "NETWORK1" and second - "NETWORK2".
  3. For "NETWORK2" add "option isolate '1'" to the wireless config.
  4. Apply the settings.
  5. Connect two devices to the "NETWORK1".
  6. Giving device one, try to ping device 2, having both devices connected to "NETWORK1".

Actual result: device 2 can't be reached from device 1 in the "NETWORK1".
Expected result: device 2 can be reached from device 1 in the "NETWORK1".

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
Projects
None yet
Development

No branches or pull requests

1 participant