OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Medium
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by makadizsolt - 18.11.2020

FS#3462 - libopenssl1.1 is not available in any repository

Dear Maintainer,

I updated my Asus AC65P router yesterday with a fresh SNAPSHOT sysupgrade image r14954-aafbfc6ac3

It generally works fine, but when I tried to install the samba4-server package with opkg (or from LuCI) I got the error:

“Required dependency package libopenssl1.1 is not available in any repository.”

Checking the base packages file (https://downloads.openwrt.org/snapshots/packages/mipsel_24kc/base/Packages.gz) it’s not there.
According to it’s package info page (https://openwrt.org/packages/pkgdata/libopenssl1.1), it should be.
And finally, I was able to install and use the samba4-server package a couple of weeks earlier without any problems.

Kind regards,
Zsolt


23.11.2020 : A task closure has been requested. Reason for request: The libopenssl1 package is available after the earlier referred patch was merged
MikePetullo commented on 18.11.2020 20:09

Is this related to http://lists.openwrt.org/pipermail/openwrt-devel/2020-November/032113.html? It seems the openssl package presently fails to build on OpenWrt master. See also https://downloads.openwrt.org/snapshots/faillogs/x86_64/base/openssl/compile.txt.

makadizsolt commented on 18.11.2020 21:10

Yes, this should be the reason, and the same error occurred during the mipsel_24kc build that you linked for x86_64:
https://downloads.openwrt.org/snapshots/faillogs/mipsel_24kc/base/openssl/compile.txt

makadizsolt commented on 19.11.2020 22:38

This issue should be solved soon, because after this mail: http://lists.openwrt.org/pipermail/openwrt-devel/2020-November/032183.html a patch have been merged today.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing