OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Medium
  • Priority Very Low
  • Reported Version openwrt-19.07
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Daniel F. Dickinson - 16.11.2020

FS#3454 - Netgear WNDR3800 VLAN switch broken 19.07.4

Supply the following if possible:
- Device problem occurs on
- Software versions of OpenWrt/LEDE release, packages, etc.
- Steps to reproduce

 

With the latest release of OpenWrt (19.07.4) using a VLAN > 16 fails. It’s rather strange as this was a problem years ago with the RTL8366s switch on these devices. I verified the firmware is reporting itself as 19.07.4 (I wondered if the files got mixed up and I was using some 18.xx version due to issues with the download site, but that is not the case).

As long as the VLAN/VID are below 16 everything works properly, but for a VLAN > 16 (regardless of whether one keeps the VLAN ⇐ 16 and only sets the VID to the actual VLAN (e.g. to match a switch into which the WNDR3800 is plugged).
For now I’ve just been disabling the switch and configuring software VLAN and letting the other switch sort out tagging/untagging.

I did some experimenting and it looks like the switch config has had some kind of weird regression.

I don’t have a spare device (and am not set up for developing / building OpenWrt at the moment), so this is more of placeholder bug until someone with resources (device / time / etc) can work on it.

On a separate note: is GitHub login deliberately disabled, or is it only me that’s having logging in with GitHub – basically is this deliberate/known or should I file a separate bug for that?

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing