OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Packages
  • Assigned To No-one
  • Operating System All
  • Severity Medium
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by dianlujitao - 24.10.2020

FS#3404 - zsh: cannot backspace when connected from openssh in tmux

Supply the following if possible:
- Device problem occurs on: NETGEAR WNDR4300
- Software versions of OpenWrt/LEDE release, packages, etc.

  • OpenWrt 19.07.4 r11208-ce6496d796
  • zsh - 5.6.2-2

- Steps to reproduce

 1. Start a tmux session on Linux PC
 2. Use ssh to connect to OpenWRT router, where the user uses zsh instead of zsh (i.e. the config in /etc/passwd looks like this `root:x:0:0:root:/root:/usr/bin/zsh`)
 3. Type arbitrary words and delete them by pressing Backspace key

- Expected behavior

 The chars are deleted

- Actual behavior

 A whitespace was appended to the char instead, as if we're typing the space key, but it's deleted internally: when pressing Enter to execute the command, what's been executed is the original command minus the deleted part

Note that I don’t have the issue when:
1. connecting to a normal Linux computer (the user’s shell is zsh ofc)
2. using the default busybox ash
3. executing ssh outside tmux, e.g. a normal Konsole terminal session

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing