OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Build Failure
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Clemens Fruhwirth - 16.10.2020
Last edited by Chuanhong Guo - 19.10.2020

FS#3387 - Mismatching kernel versions make imagebuilder fail on dependencies

My imagebuilder fails with:

 * satisfy_dependencies_for: Cannot satisfy the following dependencies for ip6tables:
 *      kernel (= 5.4.71-1-f98c0a65e4abf8ea23dca7dc54885e01)
 * opkg_install_cmd: Cannot install package ip6tables.
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-ath9k:
 *      kernel (= 5.4.71-1-f98c0a65e4abf8ea23dca7dc54885e01)
 * opkg_install_cmd: Cannot install package kmod-ath9k.
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-gpio-button-hotplug:
 *      kernel (= 5.4.71-1-f98c0a65e4abf8ea23dca7dc54885e01)
 * opkg_install_cmd: Cannot install package kmod-gpio-button-hotplug.
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-ipt-offload:
 *      kernel (= 5.4.71-1-f98c0a65e4abf8ea23dca7dc54885e01)
 * opkg_install_cmd: Cannot install package kmod-ipt-offload.
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-leds-reset:
 *      kernel (= 5.4.71-1-f98c0a65e4abf8ea23dca7dc54885e01)

and so on, when building with make image PROFILE=dlink_dir-825-b1. The build also fails with other device profiles, like PROFILE=tplink_tl-wpa8630p-v2-int and PROFILE=netgear_wndr3700. My full build log is here. From it, I can see that kernel “4.19.123-1-15bf82eb76ba9ffe9ce4bbb30765c6e0” is fetched, but seemingly non-matching kernel module packages are fetched afterwards.

Thanks, Clemens

Closed by  Chuanhong Guo
19.10.2020 10:32
Reason for closing:  Not a bug
Clemens Fruhwirth commented on 19.10.2020 10:07

Sorry, that's most likely a problem of my build directory. I kept un-tar-ing updates into that directory, and rm -fr it once, cleared the problem.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing