OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Critical
  • Priority Very Low
  • Reported Version openwrt-19.07
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Willy Gardiol - 09.10.2020
Last edited by Adrian Schmutzler - 09.10.2020

FS#3372 - After flashing 19.07.4 on Kingston MLWG2, no network are accessible and serial console MUST be used

Just flashed 19.07.4 on Kingston MLWG2.

Followed online procedure found (copy image to SD card, touch special file, login via telnet on stock firmware, write image, reboot device) to flash OpenWRT.

After flash, device “seems” stuck dead (all leds are on, wired network irresponsive, no WiFi AP detected).

I have opened the device, soldered the serial console pins and accessere via serial console.

Device is actually booting perfectly, but both wired and wifi are not accessible.

1. I have WiFi enabled by setting “disabled = 0” in /etc/config/wireless to OpenWrt AP

2. I have Wired enabled by adding “option iface “eth0”” to the “lan” interface in /etc/config/network

3. Device now works great

Without these two changes, the device is as good as dead.

This is a peculiar device: only 1 ethernet port and 2.4Ghz Wifi. My guess something is wrong in the vlan/bridge/switch settings?

I hope a fix can be commited somehow so that future users do not end up with a dead-like device.

 


Project Manager
Adrian Schmutzler commented on 09.10.2020 15:11

In 19.07, the device is set up with:
ucidef_set_interface_lan "eth0.1"

It would be interesting how your /etc/config/network looked after flashing (and what exactly you changed there). Maybe you can reconstruct without having to flash again?

Willy Gardiol commented on 09.10.2020 15:20

This was the original network file:

config interface 'loopback'
      option ifname 'lo'
      option proto 'static'
      option ipaddr '127.0.0.1'
      option netmask '255.0.0.0'

config globals 'globals'
      option ula_prefix 'fdf0:a4ca:5192::/48'

config interface 'lan'
      option type 'bridge'
      option ifname 'eth0.1'
      option proto 'static'
      option ipaddr '192.168.1.1'
      option netmask '255.255.255.0'
      option ip6assign '60'

config device 'lan_eth0_1_dev'
      option name 'eth0.1'
      option macaddr '00:26:b7:09:e9:3

While this is how i changed it (only changed section):

config interface 'lan'
      option type 'bridge'
      option proto 'static'
      option ifname 'eth0'
      option netmask '255.255.255.0'
      option ip6assign '60'
      option ipaddr '192.168.1.1'

The full story is at this forum post:

forum

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing