OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Medium
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by howl - 06.09.2020

FS#3329 - Channel 144 disabled for Europe regulatory domains when is allowed

This applies for all devices all releases.

iw list throws 5720 MHz [144] (disabled) for ES reg domain.

Channel 144 is allowed in all Europe and have the same rules as channel 140 for example, so it should be listed as:
5720 MHz [144] (26.0 dBm) (no IR, radar detection).

More info: https://en.wikipedia.org/wiki/List_of_WLAN_channels#5_GHz_or_5.9_GHz_(802.11a/h/j/n/ac/ax)

I’m not sure if this is the place to report because I think this is present also upstream in the kernel regulatory rules.

With 144 active is possible to have one more 20, 40 and 80 mhz band in Europe. The rest of the channels have been updated properly, even the 169 an 173 channels only usable in Europe and India appears as available. It’s just 144 the only one I see is not taken into account for Europe.

Dries commented on 09.09.2020 07:59

CH 144 is disabled in many early AC Wave1 devices. You can check with `iw reg get` that software side is prefect. I confirm same deficiency in V5 hardware and ath10k built in my laptop.

jnsp commented on 11.10.2020 11:50

According to this list, many client devices support channel 144.

My access point also shows

* 5720 MHz [144] (disabled)

Am I right that this is a hardware problem and there is nothing OpenWrt can do about it? The ability to use channel 144 would allow many people to use this portion of the 5 GHz band with 80 MHz channels (I guess this is what the regulators wanted when they made channel 144 available).

iw reg get shows

	(5470 - 5725 @ 160), (N/A, 26), (0 ms), DFS

on my access point but

...
	(5490 - 5730 @ 160), (6, 20), (0 ms), DFS, PASSIVE-SCAN
...

on my Linux laptop with a recent AC card from Intel.

Maybe the problem is related to the regdomain only allowing up to 5725 MHz in OpenWrt (instead of 5730 MHz on my laptop)?

jnsp commented on 11.10.2020 12:02

I have just noticed that the regdb for 00-World allows 5730 MHz (instead of 5725 MHz). If I switch the regdomain for testing purposes to 00-World, then I can select channel 144 MHz in LuCI and use it with 80 MHz bandwidth (within the range of channels 132 to 144).

Okay, the problem seems to be that the regulators allow channel 144 only to be used with 25mW and without the need for DFS (instead of up to 500mW+DFS in channel 132, 136, 140). Because of the mixed regulatory limits, we can't have an 80 MHz channel in this portion of the band.

Let's hope the regulators will change that in the future, we will need the bandwidth in the future.

Edit: This only affects EU countries, you should be able to use channel 144 with 80 MHz of bandwidth just fine in the US.

jnsp commented on 11.10.2020 12:25
Channel 144 is allowed in all Europe and have the same rules as channel 140 for example, so it should be listed as:
5720 MHz [144] (26.0 dBm) (no IR, radar detection).

This is incorrect. Channel 144 has different rules than channel 140 in the EU (see post above).

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing