OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by william wortel - 05.09.2020

FS#3321 - wireless phy, capable of bands g and a but set as AP to band g (2.4 GHz) still doing radar scan

OpenWrt SNAPSHOT, r14382+7-ad0f0df909
Ubiquiti Routerstation ar71xx with 3 pcs. PCIe 2.4/5 GHz radio
wlan0 set AP 5 GHz wlan1,2 set as AP 2.4 GHz

from dmesg:
daemon.notice hostapd: wlan2: DFS-CAC-COMPLETED success=1 freq=5640 ht_enabled=1 chan_offset=-1 chan_width=2 cf1=5630 cf2=0
daemon.warn hostapd: current_mode != IEEE80211A
daemon.notice hostapd: wlan1: DFS-CAC-COMPLETED success=1 freq=5640 ht_enabled=1 chan_offset=-1 chan_width=2 cf1=5630 cf2=0
daemon.warn hostapd: current_mode != IEEE80211A

When set to 2.4 GHz band no radar scan on 5 GHz band should be done but apparently it is being done. As the radio circuit cannot do G and A band service at the same time
this interferes with continuous service in the 80211 G band.
No idea where this 5630 GHz frequency stems from that the log shows. wlan1 is set to channel 12 and wlan2 to channel 1. Being AP they are not supposed to scan, let alone on 5 GHz.
iwinfo:
wlan0 ESSID: “some a”

        Access Point: 00:0C:42:xxxxxx
        Mode: Master  Channel: 128 (5.640 GHz)
        Tx-Power: 18 dBm  Link Quality: 70/70
        Signal: -29 dBm  Noise: -95 dBm
        Bit Rate: 81.0 MBit/s
        Encryption: WPA PSK (CCMP)
        Type: nl80211  HW Mode(s): 802.11abgn
        Hardware: 168C:0029 168C:4204 [Generic MAC80211]
        TX power offset: unknown
        Frequency offset: unknown
        Supports VAPs: yes  PHY name: phy0

wlan1 ESSID: “some b”

        Access Point: 00:1B:B1:xxxxxx
        Mode: Master  Channel: 12 (2.467 GHz)
        Tx-Power: 18 dBm  Link Quality: unknown/70
        Signal: unknown  Noise: -95 dBm
        Bit Rate: unknown
        Encryption: WPA PSK (CCMP)
        Type: nl80211  HW Mode(s): 802.11abgn
        Hardware: 168C:0029 168C:2096 [Generic MAC80211]
        TX power offset: unknown
        Frequency offset: unknown
        Supports VAPs: yes  PHY name: phy1

wlan2 ESSID: “some c”

        Access Point: 00:0C:42:xxxxxx
        Mode: Master  Channel: 1 (2.412 GHz)
        Tx-Power: 16 dBm  Link Quality: unknown/70
        Signal: unknown  Noise: -95 dBm
        Bit Rate: unknown
        Encryption: WPA PSK (CCMP)
        Type: nl80211  HW Mode(s): 802.11abgn
        Hardware: 168C:0029 168C:4204 [Generic MAC80211]
        TX power offset: unknown
        Frequency offset: unknown
        Supports VAPs: yes  PHY name: phy2
This task has the following sub-task
ID Project Summary Priority Severity Progress
3322 OpenWrt/LEDE Project  FS#3322 - correction; log stems from 'logread' , not 'dmesg'  Very Low Low
100%

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing