OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by GANDALF - 24.08.2020

FS#3304 - MVEBU - sysupgrade may not correctly detect device from bootcmd

forum topic : https://forum.openwrt.org/t/solved-19-07-xx-own-build-unflashable/72297 Solution : https://forum.openwrt.org/t/solved-19-07-xx-own-build-unflashable/72297/8

Sysupgrade do not correctly detect the device from some bootcmd uboot command line ...

I suppose, rootfs is not correctly detected ?

/proc/cmdline okay : console=ttyMV0,115200 earlycon=ar3700_uart,0xd0012000 root=/dev/mmcblk0p2 rw rootwait net.ifnames=0 biosdevname=0
/proc/cmdline which make an error : console=ttyMV0,115200 earlycon=ar3700_uart,0xd0012000 root=/dev/mmcblk0p2 rw ip=0.0.0.0:0.0.0.0:10.4.50.254:255.255.255.0:marvell:eth0:none nfsroot=0.0.0.0:/dev/mmcblk0p2

when error happend, the message is :
root@NAS:~# sysupgrade -v -T openwrt-19.07.3-mvebu-cortexa53-globalscale_espressobin-v7-emmc-ext4-sdcard.img.gz
Image not in /tmp, copying...
Unable to determine upgrade device
Image check failed.
root@NAS:~#

GANDALF commented on 24.08.2020 18:26

also from 19.07.3 and 19.07-master

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing