OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity High
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by CN_SZTL - 13.08.2020

FS#3282 - [bug/crypto] rockchip: nanopi r2s crypto performance issue

Hello everyone.

I found a serious crypto performance problem with NanoPi R2S.

Some proxy softwares, like shadowsocks-libev, can only reach to low
speed (about ~13 MB/s with aes-128-gcm). On this board, I don’t think
it’s normal.

Otherwise, all the chippers perform terriblly, not just aes-128-gcm.
I tried run commands like openssl speed -evp aes-128-gcm, and the
scores were good, but when running other softwares like trojan which
using openssl to crypt / decrypt, the speed totally doesn’t match the
score.

I’ve ever tried to enable the kernel crypto modules, but it seemded to
be useless.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing