OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Critical
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Thiago H Ribeiro - 09.08.2020

FS#3280 - Wan interface and sometimes lan interfaces randomly go up/down at the link layer

- Versions where bug is present: OpenWRT snapshots, tested with r13938 and r18039.

- Affected device: D-Link DIR-878 and likely others from its family.

- What does it do and shouldn’t do: the ethernet interfaces randomly get switched on/off, dropping the link and resetting the connection. Troubleshooting has already been thoroughly conducted to rule out other causes, see below. This is critical severity because makes OpenWRT unusable in these devices.

- Steps to reproduce:
– flash the snapshot image on a D-Link DIR-878;
– configure the WAN (tested with PPPoE and DHCP protocols) and LAN interfaces (tested with Static and DHCP protocols) - using all interfaces will increase the likelihood that at least one of them will present the behaviour;
– wait an indefinite but reasonable (< 2h for all instances so far) amount of time;
– the interface will randomly be put down and then up a couple seconds later, and it will be randomly looping up/down states at random amounts of time.

- Troubleshooting already conducted: full and detailed troubleshooting history is present at this forum thread. Please let me know if I can provide further information.

- Additional info: some people are having WiFi issues with MT7621 family devices that might be related to this one if they share a common cause, such as a possible race condition in the drivers;

Franco Castillo commented on 10.08.2020 00:52

Yes, that's why I had to go back to 19.07.3 that this problem does not happen.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing