OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Kernel
  • Assigned To No-one
  • Operating System All
  • Severity High
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Andy Walsh - 30.07.2020
Last edited by Ted Hess - 18.08.2020

FS#3260 - reduced upload speeds with enabled LAN 'flow control rx/tx'

Device: WRT-1200AC
Openwrt Version: SNAPSHOT r13982-e9f7923a1d
Kernel: 5.4.x, tried also 5.4.53

Problem/Bug:
If i keep the default ‘flow control rx/tx’ setting enabled for any LAN port, my upload speeds drop from my max 38 Mbit/s to 10 Mbit/s. Same happens if i put a unmanaged switch behind the router, that has RX/TX enabled and any device behind the switch than gets the reduced 10 Mbit/s upload speeds. The download speeds are unaffected, only the upload speed drops.

Steps to reproduce:
Just disable/enable ‘flow control’ on the client side for any LAN port. This bug happens independent of client OS/Network card used. Just enable/disable “Flow Control” in the Win10 adapter property page, than do some upload tests.

mv88e6085 f1072004.mdio-mii:00 lan1: Link is Up - 1Gbps/Full - flow control rx/tx

vs

mv88e6085 f1072004.mdio-mii:00 lan1: Link is Up - 1Gbps/Full - flow control off

PS: This worked fine before and i think started with the 5.4.x kernels on mvebu.

Closed by  Ted Hess
18.08.2020 17:04
Reason for closing:  Fixed
Andy Walsh commented on 30.07.2020 22:15

Quick addition the WAN port has flow control enabled in both cases.

mv88e6085 f1072004.mdio-mii:00 wan: Link is Up - 1Gbps/Full - flow control rx/tx
Andy Walsh commented on 16.08.2020 12:12

seems fixed in latest master kernel 5.4.57

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing