OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Kernel
  • Assigned To
    Chuanhong Guo
  • Operating System All
  • Severity High
  • Priority High
  • Reported Version openwrt-19.07
  • Due in Version Undecided
  • Due Date 30.09.2020
    21 days overdue
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Stanislav German-Evtushenko - 12.07.2020
Last edited by Chuanhong Guo - 11.10.2020

FS#3226 - GL-AR300M: Frequent WAN (eth1) link down / link up

Trying to find a solution for the issue with Wi-Fi on the latest stable release (19.07.3) installed a snapshot version if OpenWrt. I’m not sure if Wi-Fi issue is solved (difficult to test in the current situation) but there is another problem now which was not happening on the stable branch: WAN link (eth1) goes up and down all the time.

Details:
- Device: GL-AR300M
- OpenWrt Version: OpenWrt SNAPSHOT r13770-edbc8e5512 / LuCI Master git-20.190.40190-44b0fcb
- Kernel: Linux OpenWrt 5.4.50 #0 Fri Jul 10 09:39:05 2020 mips GNU/Linux
- OpenWrt snapshot downloaded from https://downloads.openwrt.org/snapshots/targets/ath79/nand/openwrt-ath79-nand-glinet_gl-ar300m-nor-squashfs-sysupgrade.bin

Configuration:
- WAN6: eth1, DHCPv6
- WAN: ds-lite (IPv4 over IPv6)
- LAN: eth0 + wlan0

How to reproduce:
1. Flash firmware
2. Install ds-lite and luci and reboot
3. Configure WAN as DS-LITE
4. Configure Wi-Fi
5. Connect to Wi-Fi and start using internet

Result: internet access disappears for short time frequently at random times

Relevant logs:

Sun Jul 12 13:14:37 2020 kern.info kernel: [  270.462928] eth1: link down
Sun Jul 12 13:14:37 2020 daemon.notice netifd: Network device 'eth1' link is down
Sun Jul 12 13:14:37 2020 daemon.notice netifd: Interface 'wan6' has link connectivity loss
Sun Jul 12 13:14:37 2020 daemon.notice netifd: wan6 (1516): Command failed: Permission denied
Sun Jul 12 13:14:38 2020 daemon.notice netifd: Interface 'wan6' is now down
Sun Jul 12 13:14:38 2020 daemon.notice netifd: Interface 'wan' has lost the connection
Sun Jul 12 13:14:38 2020 daemon.warn dnsmasq[1648]: no servers found in /tmp/resolv.conf.d/resolv.conf.auto, will retry
Sun Jul 12 13:14:38 2020 daemon.notice netifd: Interface 'wan6' is disabled
Sun Jul 12 13:14:38 2020 daemon.notice netifd: Interface 'wan6' is enabled
Sun Jul 12 13:14:38 2020 daemon.err odhcpd[1081]: Failed to send to ff02::2%wan6@eth1 (Permission denied)
Sun Jul 12 13:14:38 2020 daemon.notice netifd: tunnel 'ds-wan' link is down
Sun Jul 12 13:14:38 2020 daemon.notice netifd: Interface 'wan' is now down
Sun Jul 12 13:14:38 2020 daemon.notice netifd: Interface 'wan' is setting up now
Sun Jul 12 13:14:38 2020 daemon.notice netifd: Interface 'wan' is now down
Sun Jul 12 13:14:40 2020 kern.info kernel: [  273.310452] eth1: link up (100Mbps/Full duplex)
Sun Jul 12 13:14:40 2020 kern.info kernel: [  273.316609] IPv6: ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
Sun Jul 12 13:14:40 2020 daemon.notice netifd: Network device 'eth1' link is up
Sun Jul 12 13:14:40 2020 daemon.notice netifd: Interface 'wan6' has link connectivity
Sun Jul 12 13:14:40 2020 daemon.notice netifd: Interface 'wan6' is setting up now
Sun Jul 12 13:14:40 2020 daemon.err odhcp6c[2092]: Failed to send RS (Address not available)
Sun Jul 12 13:14:41 2020 daemon.err odhcp6c[2092]: Failed to send DHCPV6 message to ff02::1:2 (Address not available)
Sun Jul 12 13:14:42 2020 daemon.err odhcp6c[2092]: Failed to send DHCPV6 message to ff02::1:2 (Address not available)
Sun Jul 12 13:14:44 2020 daemon.err odhcp6c[2092]: Failed to send RS (Address not available)
Sun Jul 12 13:14:44 2020 daemon.err odhcp6c[2092]: Failed to send DHCPV6 message to ff02::1:2 (Address not available)
Sun Jul 12 13:14:48 2020 daemon.err odhcp6c[2092]: Failed to send RS (Address not available)
Sun Jul 12 13:14:49 2020 daemon.err odhcp6c[2092]: Failed to send DHCPV6 message to ff02::1:2 (Address not available)
Sun Jul 12 13:15:00 2020 daemon.notice netifd: Interface 'wan' is setting up now
Sun Jul 12 13:15:00 2020 daemon.notice netifd: Interface 'wan6' is now up
Sun Jul 12 13:15:00 2020 daemon.info dnsmasq[1648]: reading /tmp/resolv.conf.d/resolv.conf.auto
Sun Jul 12 13:15:00 2020 daemon.info dnsmasq[1648]: using only locally-known addresses for domain test
Sun Jul 12 13:15:00 2020 daemon.info dnsmasq[1648]: using only locally-known addresses for domain onion
Sun Jul 12 13:15:00 2020 daemon.info dnsmasq[1648]: using only locally-known addresses for domain localhost
Sun Jul 12 13:15:00 2020 daemon.info dnsmasq[1648]: using only locally-known addresses for domain local
Sun Jul 12 13:15:00 2020 daemon.info dnsmasq[1648]: using only locally-known addresses for domain invalid
Sun Jul 12 13:15:00 2020 daemon.info dnsmasq[1648]: using only locally-known addresses for domain bind
Sun Jul 12 13:15:00 2020 daemon.info dnsmasq[1648]: using only locally-known addresses for domain lan
Sun Jul 12 13:15:00 2020 daemon.info dnsmasq[1648]: using nameserver 2404:1a8:7f01:b::3#53
Sun Jul 12 13:15:00 2020 daemon.info dnsmasq[1648]: using nameserver 2404:1a8:7f01:a::3#53
Sun Jul 12 13:15:00 2020 user.notice firewall: Reloading firewall due to ifup of wan6 (eth1)
Sun Jul 12 13:15:09 2020 daemon.notice netifd: Interface 'wan' is now down
Sun Jul 12 13:15:09 2020 daemon.notice netifd: Interface 'wan' is setting up now
Sun Jul 12 13:15:12 2020 daemon.notice netifd: Interface 'wan' is now up
Sun Jul 12 13:15:12 2020 daemon.notice netifd: tunnel 'ds-wan' link is up
Sun Jul 12 13:15:13 2020 user.notice firewall: Reloading firewall due to ifup of wan (ds-wan)
--
Sun Jul 12 13:22:48 2020 kern.info kernel: [  761.753793] eth1: link down
Sun Jul 12 13:22:48 2020 daemon.notice netifd: Network device 'eth1' link is down
Sun Jul 12 13:22:48 2020 daemon.notice netifd: Interface 'wan6' has link connectivity loss
Sun Jul 12 13:22:49 2020 daemon.notice netifd: wan6 (2092): Command failed: Permission denied
Sun Jul 12 13:22:49 2020 daemon.notice netifd: Interface 'wan6' is now down
Sun Jul 12 13:22:49 2020 daemon.notice netifd: Interface 'wan' has lost the connection
Sun Jul 12 13:22:49 2020 daemon.warn dnsmasq[1648]: no servers found in /tmp/resolv.conf.d/resolv.conf.auto, will retry
Sun Jul 12 13:22:49 2020 daemon.notice netifd: Interface 'wan6' is disabled
Sun Jul 12 13:22:49 2020 daemon.notice netifd: Interface 'wan6' is enabled
Sun Jul 12 13:22:49 2020 daemon.err odhcpd[1081]: Failed to send to ff02::2%wan6@eth1 (Permission denied)
Sun Jul 12 13:22:49 2020 daemon.notice netifd: tunnel 'ds-wan' link is down
Sun Jul 12 13:22:49 2020 daemon.notice netifd: Interface 'wan' is now down
Sun Jul 12 13:22:49 2020 daemon.notice netifd: Interface 'wan' is setting up now
Sun Jul 12 13:22:49 2020 daemon.notice netifd: Interface 'wan' is now down
Sun Jul 12 13:22:51 2020 kern.info kernel: [  764.027453] eth1: link up (100Mbps/Full duplex)
Sun Jul 12 13:22:51 2020 kern.info kernel: [  764.033121] IPv6: ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
Sun Jul 12 13:22:51 2020 daemon.notice netifd: Network device 'eth1' link is up
Sun Jul 12 13:22:51 2020 daemon.notice netifd: Interface 'wan6' has link connectivity
Sun Jul 12 13:22:51 2020 daemon.notice netifd: Interface 'wan6' is setting up now
Sun Jul 12 13:22:51 2020 daemon.err odhcp6c[2417]: Failed to send RS (Address not available)
Sun Jul 12 13:22:51 2020 daemon.err odhcp6c[2417]: Failed to send DHCPV6 message to ff02::1:2 (Address not available)
Sun Jul 12 13:22:52 2020 daemon.err odhcp6c[2417]: Failed to send DHCPV6 message to ff02::1:2 (Address not available)
Sun Jul 12 13:22:54 2020 daemon.err odhcp6c[2417]: Failed to send DHCPV6 message to ff02::1:2 (Address not available)
Sun Jul 12 13:22:55 2020 daemon.err odhcpd[1081]: Failed to send to ff02::2%wan6@eth1 (Address not available)
Sun Jul 12 13:22:55 2020 daemon.err odhcp6c[2417]: Failed to send RS (Address not available)
Sun Jul 12 13:22:59 2020 daemon.err odhcp6c[2417]: Failed to send DHCPV6 message to ff02::1:2 (Address not available)
Sun Jul 12 13:22:59 2020 daemon.err odhcp6c[2417]: Failed to send RS (Address not available)
Sun Jul 12 13:23:10 2020 daemon.notice netifd: Interface 'wan' is setting up now
Sun Jul 12 13:23:10 2020 daemon.notice netifd: Interface 'wan6' is now up
Sun Jul 12 13:23:10 2020 daemon.info dnsmasq[1648]: reading /tmp/resolv.conf.d/resolv.conf.auto
Sun Jul 12 13:23:10 2020 daemon.info dnsmasq[1648]: using only locally-known addresses for domain test
Sun Jul 12 13:23:10 2020 daemon.info dnsmasq[1648]: using only locally-known addresses for domain onion
Sun Jul 12 13:23:10 2020 daemon.info dnsmasq[1648]: using only locally-known addresses for domain localhost
Sun Jul 12 13:23:10 2020 daemon.info dnsmasq[1648]: using only locally-known addresses for domain local
Sun Jul 12 13:23:10 2020 daemon.info dnsmasq[1648]: using only locally-known addresses for domain invalid
Sun Jul 12 13:23:10 2020 daemon.info dnsmasq[1648]: using only locally-known addresses for domain bind
Sun Jul 12 13:23:10 2020 daemon.info dnsmasq[1648]: using only locally-known addresses for domain lan
Sun Jul 12 13:23:10 2020 daemon.info dnsmasq[1648]: using nameserver 2404:1a8:7f01:b::3#53
Sun Jul 12 13:23:10 2020 daemon.info dnsmasq[1648]: using nameserver 2404:1a8:7f01:a::3#53
Sun Jul 12 13:23:10 2020 user.notice firewall: Reloading firewall due to ifup of wan6 (eth1)
Sun Jul 12 13:23:10 2020 daemon.notice netifd: Interface 'wan' is now up
Sun Jul 12 13:23:10 2020 daemon.notice netifd: tunnel 'ds-wan' link is up
Sun Jul 12 13:23:11 2020 user.notice firewall: Reloading firewall due to ifup of wan (ds-wan)
Sun Jul 12 13:23:14 2020 kern.warn kernel: [  786.791642] ip6_tunnel: ds-wan xmit: Local address not yet configured!
Sun Jul 12 13:23:14 2020 kern.warn kernel: [  786.805226] ip6_tunnel: ds-wan xmit: Local address not yet configured!
Sun Jul 12 13:23:14 2020 kern.warn kernel: [  787.614693] ip6_tunnel: ds-wan xmit: Local address not yet configured!
Sun Jul 12 13:23:14 2020 kern.warn kernel: [  787.646373] ip6_tunnel: ds-wan xmit: Local address not yet configured!
Sun Jul 12 13:23:15 2020 kern.warn kernel: [  788.144143] ip6_tunnel: ds-wan xmit: Local address not yet configured!
Sun Jul 12 13:23:15 2020 kern.warn kernel: [  788.432037] ip6_tunnel: ds-wan xmit: Local address not yet configured!
Sun Jul 12 13:23:15 2020 kern.warn kernel: [  788.485928] ip6_tunnel: ds-wan xmit: Local address not yet configured!
Sun Jul 12 13:57:08 2020 kern.info kernel: [ 2821.238040] eth1: link down
Sun Jul 12 13:57:08 2020 daemon.notice netifd: Network device 'eth1' link is down
Sun Jul 12 13:57:08 2020 daemon.notice netifd: Interface 'wan6' has link connectivity loss
Sun Jul 12 13:57:08 2020 daemon.notice netifd: wan6 (2417): Command failed: Permission denied
Sun Jul 12 13:57:08 2020 daemon.notice netifd: Interface 'wan6' is now down
Sun Jul 12 13:57:08 2020 daemon.notice netifd: Interface 'wan' has lost the connection
Sun Jul 12 13:57:08 2020 daemon.warn dnsmasq[1648]: no servers found in /tmp/resolv.conf.d/resolv.conf.auto, will retry
Sun Jul 12 13:57:08 2020 daemon.notice netifd: Interface 'wan6' is disabled
Sun Jul 12 13:57:08 2020 daemon.notice netifd: Interface 'wan6' is enabled
Sun Jul 12 13:57:08 2020 daemon.err odhcpd[1081]: Failed to send to ff02::2%wan6@eth1 (Permission denied)
Sun Jul 12 13:57:08 2020 daemon.notice netifd: tunnel 'ds-wan' link is down
Sun Jul 12 13:57:08 2020 daemon.notice netifd: Interface 'wan' is now down
Sun Jul 12 13:57:08 2020 daemon.notice netifd: Interface 'wan' is setting up now
Sun Jul 12 13:57:09 2020 daemon.notice netifd: Interface 'wan' is now down
Sun Jul 12 13:57:10 2020 kern.info kernel: [ 2823.511539] eth1: link up (100Mbps/Full duplex)
Sun Jul 12 13:57:10 2020 daemon.notice netifd: Network device 'eth1' link is up
Sun Jul 12 13:57:10 2020 daemon.notice netifd: Interface 'wan6' has link connectivity
Sun Jul 12 13:57:10 2020 daemon.notice netifd: Interface 'wan6' is setting up now
Sun Jul 12 13:57:10 2020 kern.info kernel: [ 2823.516453] IPv6: ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
Sun Jul 12 13:57:10 2020 daemon.err odhcp6c[2733]: Failed to send RS (Address not available)
Sun Jul 12 13:57:11 2020 daemon.err odhcp6c[2733]: Failed to send DHCPV6 message to ff02::1:2 (Address not available)
Sun Jul 12 13:57:12 2020 daemon.err odhcp6c[2733]: Failed to send DHCPV6 message to ff02::1:2 (Address not available)
Sun Jul 12 13:57:14 2020 daemon.err odhcp6c[2733]: Failed to send RS (Address not available)
Sun Jul 12 13:57:14 2020 daemon.err odhcp6c[2733]: Failed to send DHCPV6 message to ff02::1:2 (Address not available)
Sun Jul 12 13:57:18 2020 daemon.err odhcp6c[2733]: Failed to send RS (Address not available)
Sun Jul 12 13:57:19 2020 daemon.err odhcp6c[2733]: Failed to send DHCPV6 message to ff02::1:2 (Address not available)
Sun Jul 12 13:57:29 2020 daemon.notice netifd: Interface 'wan' is setting up now
Sun Jul 12 13:57:29 2020 daemon.notice netifd: Interface 'wan6' is now up
Sun Jul 12 13:57:29 2020 daemon.info dnsmasq[1648]: reading /tmp/resolv.conf.d/resolv.conf.auto
Sun Jul 12 13:57:29 2020 daemon.info dnsmasq[1648]: using only locally-known addresses for domain test
Sun Jul 12 13:57:29 2020 daemon.info dnsmasq[1648]: using only locally-known addresses for domain onion
Sun Jul 12 13:57:29 2020 daemon.info dnsmasq[1648]: using only locally-known addresses for domain localhost
Sun Jul 12 13:57:29 2020 daemon.info dnsmasq[1648]: using only locally-known addresses for domain local
Sun Jul 12 13:57:29 2020 daemon.info dnsmasq[1648]: using only locally-known addresses for domain invalid
Sun Jul 12 13:57:29 2020 daemon.info dnsmasq[1648]: using only locally-known addresses for domain bind
Sun Jul 12 13:57:29 2020 daemon.info dnsmasq[1648]: using only locally-known addresses for domain lan
Sun Jul 12 13:57:29 2020 daemon.info dnsmasq[1648]: using nameserver 2404:1a8:7f01:b::3#53
Sun Jul 12 13:57:29 2020 daemon.info dnsmasq[1648]: using nameserver 2404:1a8:7f01:a::3#53
Sun Jul 12 13:57:30 2020 user.notice firewall: Reloading firewall due to ifup of wan6 (eth1)
Sun Jul 12 13:57:30 2020 daemon.notice netifd: Interface 'wan' is now up
Sun Jul 12 13:57:30 2020 daemon.notice netifd: tunnel 'ds-wan' link is up
Sun Jul 12 13:57:30 2020 user.notice firewall: Reloading firewall due to ifup of wan (ds-wan)
Sun Jul 12 13:57:31 2020 kern.warn kernel: [ 2844.695917] ip6_tunnel: ds-wan xmit: Local address not yet configured!
Sun Jul 12 13:57:34 2020 kern.warn kernel: [ 2847.142196] ip6_tunnel: ds-wan xmit: Local address not yet configured!
--
Sun Jul 12 14:18:30 2020 kern.info kernel: [ 4103.506462] eth1: link down
Sun Jul 12 14:18:30 2020 daemon.notice netifd: Network device 'eth1' link is down
Sun Jul 12 14:18:30 2020 daemon.notice netifd: Interface 'wan6' has link connectivity loss
Sun Jul 12 14:18:30 2020 daemon.notice netifd: wan6 (2733): Command failed: Permission denied
Sun Jul 12 14:18:30 2020 daemon.notice netifd: Interface 'wan6' is now down
Sun Jul 12 14:18:30 2020 daemon.notice netifd: Interface 'wan' has lost the connection
Sun Jul 12 14:18:30 2020 daemon.warn dnsmasq[1648]: no servers found in /tmp/resolv.conf.d/resolv.conf.auto, will retry
Sun Jul 12 14:18:30 2020 daemon.notice netifd: Interface 'wan6' is disabled
Sun Jul 12 14:18:30 2020 daemon.notice netifd: Interface 'wan6' is enabled
Sun Jul 12 14:18:30 2020 daemon.err odhcpd[1081]: Failed to send to ff02::2%wan6@eth1 (Permission denied)
Sun Jul 12 14:18:30 2020 daemon.notice netifd: tunnel 'ds-wan' link is down
Sun Jul 12 14:18:31 2020 daemon.notice netifd: Interface 'wan' is now down
Sun Jul 12 14:18:31 2020 daemon.notice netifd: Interface 'wan' is setting up now
Sun Jul 12 14:18:31 2020 daemon.notice netifd: Interface 'wan' is now down
Sun Jul 12 14:18:33 2020 kern.info kernel: [ 4105.782348] eth1: link up (100Mbps/Full duplex)
Sun Jul 12 14:18:33 2020 daemon.notice netifd: Network device 'eth1' link is up
Sun Jul 12 14:18:33 2020 daemon.notice netifd: Interface 'wan6' has link connectivity
Sun Jul 12 14:18:33 2020 daemon.notice netifd: Interface 'wan6' is setting up now
Sun Jul 12 14:18:33 2020 kern.info kernel: [ 4105.787321] IPv6: ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
Sun Jul 12 14:18:33 2020 daemon.err odhcp6c[3024]: Failed to send RS (Address not available)
Sun Jul 12 14:18:33 2020 daemon.err odhcp6c[3024]: Failed to send DHCPV6 message to ff02::1:2 (Address not available)
Sun Jul 12 14:18:34 2020 daemon.err odhcp6c[3024]: Failed to send DHCPV6 message to ff02::1:2 (Address not available)
Sun Jul 12 14:18:36 2020 daemon.err odhcp6c[3024]: Failed to send DHCPV6 message to ff02::1:2 (Address not available)
Sun Jul 12 14:18:37 2020 daemon.err odhcp6c[3024]: Failed to send RS (Address not available)
Sun Jul 12 14:18:40 2020 daemon.err odhcp6c[3024]: Failed to send DHCPV6 message to ff02::1:2 (Address not available)
Sun Jul 12 14:18:41 2020 daemon.err odhcp6c[3024]: Failed to send RS (Address not available)
Sun Jul 12 14:18:51 2020 daemon.notice netifd: Interface 'wan' is setting up now
Sun Jul 12 14:18:51 2020 daemon.notice netifd: Interface 'wan6' is now up
Sun Jul 12 14:18:51 2020 daemon.info dnsmasq[1648]: reading /tmp/resolv.conf.d/resolv.conf.auto
Sun Jul 12 14:18:51 2020 daemon.info dnsmasq[1648]: using only locally-known addresses for domain test
Sun Jul 12 14:18:51 2020 daemon.info dnsmasq[1648]: using only locally-known addresses for domain onion
Sun Jul 12 14:18:51 2020 daemon.info dnsmasq[1648]: using only locally-known addresses for domain localhost
Sun Jul 12 14:18:51 2020 daemon.info dnsmasq[1648]: using only locally-known addresses for domain local
Sun Jul 12 14:18:51 2020 daemon.info dnsmasq[1648]: using only locally-known addresses for domain invalid
Sun Jul 12 14:18:51 2020 daemon.info dnsmasq[1648]: using only locally-known addresses for domain bind
Sun Jul 12 14:18:51 2020 daemon.info dnsmasq[1648]: using only locally-known addresses for domain lan
Sun Jul 12 14:18:51 2020 daemon.info dnsmasq[1648]: using nameserver 2404:1a8:7f01:b::3#53
Sun Jul 12 14:18:51 2020 daemon.info dnsmasq[1648]: using nameserver 2404:1a8:7f01:a::3#53
Sun Jul 12 14:18:52 2020 user.notice firewall: Reloading firewall due to ifup of wan6 (eth1)
Sun Jul 12 14:18:52 2020 daemon.notice netifd: Interface 'wan' is now up
Sun Jul 12 14:18:52 2020 daemon.notice netifd: tunnel 'ds-wan' link is up
Sun Jul 12 14:18:52 2020 user.notice firewall: Reloading firewall due to ifup of wan (ds-wan)
Sun Jul 12 14:18:54 2020 kern.warn kernel: [ 4127.330490] ip6_tunnel: ds-wan xmit: Local address not yet configured!
Sun Jul 12 14:18:54 2020 kern.warn kernel: [ 4127.712988] ip6_tunnel: ds-wan xmit: Local address not yet configured!
Sun Jul 12 14:18:55 2020 kern.warn kernel: [ 4128.223311] ip6_tunnel: ds-wan xmit: Local address not yet configured!
Sun Jul 12 14:18:56 2020 kern.warn kernel: [ 4129.508799] ip6_tunnel: ds-wan xmit: Local address not yet configured!
Sun Jul 12 14:18:56 2020 kern.warn kernel: [ 4129.515926] ip6_tunnel: ds-wan xmit: Local address not yet configured!
Sun Jul 12 14:18:56 2020 kern.warn kernel: [ 4129.538444] ip6_tunnel: ds-wan xmit: Local address not yet configured!
Sun Jul 12 14:18:56 2020 kern.warn kernel: [ 4129.757929] ip6_tunnel: ds-wan xmit: Local address not yet configured!
Sun Jul 12 14:18:57 2020 kern.warn kernel: [ 4129.970986] ip6_tunnel: ds-wan xmit: Local address not yet configured!
Sun Jul 12 14:18:57 2020 kern.warn kernel: [ 4130.402844] ip6_tunnel: ds-wan xmit: Local address not yet configured!
--
Sun Jul 12 14:20:33 2020 kern.info kernel: [ 4226.612658] eth1: link down
Sun Jul 12 14:20:33 2020 daemon.notice netifd: Network device 'eth1' link is down
Sun Jul 12 14:20:33 2020 daemon.notice netifd: Interface 'wan6' has link connectivity loss
Sun Jul 12 14:20:33 2020 daemon.notice netifd: wan6 (3024): Command failed: Permission denied
Sun Jul 12 14:20:34 2020 daemon.notice netifd: Interface 'wan6' is now down
Sun Jul 12 14:20:34 2020 daemon.notice netifd: Interface 'wan' has lost the connection
Sun Jul 12 14:20:34 2020 daemon.warn dnsmasq[1648]: no servers found in /tmp/resolv.conf.d/resolv.conf.auto, will retry
Sun Jul 12 14:20:34 2020 daemon.notice netifd: Interface 'wan6' is disabled
Sun Jul 12 14:20:34 2020 daemon.notice netifd: Interface 'wan6' is enabled
Sun Jul 12 14:20:34 2020 daemon.err odhcpd[1081]: Failed to send to ff02::2%wan6@eth1 (Permission denied)
Sun Jul 12 14:20:34 2020 daemon.notice netifd: tunnel 'ds-wan' link is down
Sun Jul 12 14:20:34 2020 daemon.notice netifd: Interface 'wan' is now down
Sun Jul 12 14:20:34 2020 daemon.notice netifd: Interface 'wan' is setting up now
Sun Jul 12 14:20:34 2020 daemon.notice netifd: Interface 'wan' is now down
Sun Jul 12 14:20:36 2020 kern.info kernel: [ 4229.236067] eth1: link up (100Mbps/Full duplex)
Sun Jul 12 14:20:36 2020 daemon.notice netifd: Network device 'eth1' link is up
Sun Jul 12 14:20:36 2020 daemon.notice netifd: Interface 'wan6' has link connectivity
Sun Jul 12 14:20:36 2020 daemon.notice netifd: Interface 'wan6' is setting up now
Sun Jul 12 14:20:36 2020 kern.info kernel: [ 4229.241354] IPv6: ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
Sun Jul 12 14:20:36 2020 daemon.err odhcp6c[3245]: Failed to send RS (Address not available)
Sun Jul 12 14:20:36 2020 daemon.err odhcp6c[3245]: Failed to send DHCPV6 message to ff02::1:2 (Address not available)
Sun Jul 12 14:20:37 2020 daemon.err odhcp6c[3245]: Failed to send DHCPV6 message to ff02::1:2 (Address not available)
Sun Jul 12 14:20:39 2020 daemon.err odhcp6c[3245]: Failed to send DHCPV6 message to ff02::1:2 (Address not available)
Sun Jul 12 14:20:40 2020 daemon.err odhcp6c[3245]: Failed to send RS (Address not available)
Sun Jul 12 14:20:44 2020 daemon.err odhcp6c[3245]: Failed to send DHCPV6 message to ff02::1:2 (Address not available)
Sun Jul 12 14:20:44 2020 daemon.err odhcp6c[3245]: Failed to send RS (Address not available)
Sun Jul 12 14:20:53 2020 daemon.notice netifd: Interface 'wan' is setting up now
Sun Jul 12 14:20:53 2020 daemon.notice netifd: Interface 'wan6' is now up
Sun Jul 12 14:20:53 2020 daemon.info dnsmasq[1648]: reading /tmp/resolv.conf.d/resolv.conf.auto
Sun Jul 12 14:20:53 2020 daemon.info dnsmasq[1648]: using only locally-known addresses for domain test
Sun Jul 12 14:20:53 2020 daemon.info dnsmasq[1648]: using only locally-known addresses for domain onion
Sun Jul 12 14:20:53 2020 daemon.info dnsmasq[1648]: using only locally-known addresses for domain localhost
Sun Jul 12 14:20:53 2020 daemon.info dnsmasq[1648]: using only locally-known addresses for domain local
Sun Jul 12 14:20:53 2020 daemon.info dnsmasq[1648]: using only locally-known addresses for domain invalid
Sun Jul 12 14:20:53 2020 daemon.info dnsmasq[1648]: using only locally-known addresses for domain bind
Sun Jul 12 14:20:53 2020 daemon.info dnsmasq[1648]: using only locally-known addresses for domain lan
Sun Jul 12 14:20:53 2020 daemon.info dnsmasq[1648]: using nameserver 2404:1a8:7f01:b::3#53
Sun Jul 12 14:20:53 2020 daemon.info dnsmasq[1648]: using nameserver 2404:1a8:7f01:a::3#53
Sun Jul 12 14:20:54 2020 user.notice firewall: Reloading firewall due to ifup of wan6 (eth1)
Sun Jul 12 14:20:54 2020 daemon.notice netifd: Interface 'wan' is now up
Sun Jul 12 14:20:54 2020 daemon.notice netifd: tunnel 'ds-wan' link is up
Sun Jul 12 14:20:54 2020 user.notice firewall: Reloading firewall due to ifup of wan (ds-wan)
Sun Jul 12 14:20:56 2020 kern.warn kernel: [ 4249.285153] ip6_tunnel: ds-wan xmit: Local address not yet configured!
Sun Jul 12 14:20:57 2020 kern.warn kernel: [ 4250.564523] ip6_tunnel: ds-wan xmit: Local address not yet configured!
Sun Jul 12 14:21:02 2020 kern.warn kernel: [ 4254.919989] ip6_tunnel: ds-wan xmit: Local address not yet configured!
Sun Jul 12 14:24:41 2020 user.notice : Added device handler type: 8021ad
Sun Jul 12 14:24:41 2020 user.notice : Added device handler type: 8021q
Sun Jul 12 14:24:41 2020 user.notice : Added device handler type: macvlan
Sun Jul 12 14:24:41 2020 user.notice : Added device handler type: veth
Sun Jul 12 14:24:41 2020 user.notice : Added device handler type: bridge
Sun Jul 12 14:24:41 2020 user.notice : Added device handler type: Network device
--
Sun Jul 12 14:37:34 2020 kern.info kernel: [ 5247.087682] eth1: link down
Sun Jul 12 14:37:34 2020 daemon.notice netifd: Network device 'eth1' link is down
Sun Jul 12 14:37:34 2020 daemon.notice netifd: Interface 'wan6' has link connectivity loss
Sun Jul 12 14:37:34 2020 daemon.notice netifd: wan6 (3245): Command failed: Permission denied
Sun Jul 12 14:37:34 2020 daemon.notice netifd: Interface 'wan6' is now down
Sun Jul 12 14:37:34 2020 daemon.notice netifd: Interface 'wan' has lost the connection
Sun Jul 12 14:37:34 2020 daemon.warn dnsmasq[1648]: no servers found in /tmp/resolv.conf.d/resolv.conf.auto, will retry
Sun Jul 12 14:37:34 2020 daemon.notice netifd: Interface 'wan6' is disabled
Sun Jul 12 14:37:34 2020 daemon.notice netifd: Interface 'wan6' is enabled
Sun Jul 12 14:37:34 2020 daemon.err odhcpd[1081]: Failed to send to ff02::2%wan6@eth1 (Permission denied)
Sun Jul 12 14:37:34 2020 daemon.notice netifd: tunnel 'ds-wan' link is down
Sun Jul 12 14:37:34 2020 daemon.notice netifd: Interface 'wan' is now down
Sun Jul 12 14:37:34 2020 daemon.notice netifd: Interface 'wan' is setting up now
Sun Jul 12 14:37:34 2020 daemon.notice netifd: Interface 'wan' is now down
Sun Jul 12 14:37:36 2020 kern.info kernel: [ 5249.361066] eth1: link up (100Mbps/Full duplex)
Sun Jul 12 14:37:36 2020 daemon.notice netifd: Network device 'eth1' link is up
Sun Jul 12 14:37:36 2020 daemon.notice netifd: Interface 'wan6' has link connectivity
Sun Jul 12 14:37:36 2020 daemon.notice netifd: Interface 'wan6' is setting up now
Sun Jul 12 14:37:36 2020 kern.info kernel: [ 5249.366018] IPv6: ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
Sun Jul 12 14:37:36 2020 daemon.err odhcp6c[3511]: Failed to send RS (Address not available)
Sun Jul 12 14:37:36 2020 daemon.err odhcp6c[3511]: Failed to send DHCPV6 message to ff02::1:2 (Address not available)
Sun Jul 12 14:37:37 2020 daemon.err odhcp6c[3511]: Failed to send DHCPV6 message to ff02::1:2 (Address not available)
Sun Jul 12 14:37:39 2020 daemon.err odhcp6c[3511]: Failed to send DHCPV6 message to ff02::1:2 (Address not available)
Sun Jul 12 14:37:40 2020 daemon.err odhcp6c[3511]: Failed to send RS (Address not available)
Sun Jul 12 14:37:43 2020 daemon.err odhcp6c[3511]: Failed to send DHCPV6 message to ff02::1:2 (Address not available)
Sun Jul 12 14:37:44 2020 daemon.err odhcp6c[3511]: Failed to send RS (Address not available)
Sun Jul 12 14:37:54 2020 daemon.notice netifd: Interface 'wan' is setting up now
Sun Jul 12 14:37:54 2020 daemon.notice netifd: Interface 'wan6' is now up
Sun Jul 12 14:37:54 2020 daemon.info dnsmasq[1648]: reading /tmp/resolv.conf.d/resolv.conf.auto
Sun Jul 12 14:37:54 2020 daemon.info dnsmasq[1648]: using only locally-known addresses for domain test
Sun Jul 12 14:37:54 2020 daemon.info dnsmasq[1648]: using only locally-known addresses for domain onion
Sun Jul 12 14:37:54 2020 daemon.info dnsmasq[1648]: using only locally-known addresses for domain localhost
Sun Jul 12 14:37:54 2020 daemon.info dnsmasq[1648]: using only locally-known addresses for domain local
Sun Jul 12 14:37:54 2020 daemon.info dnsmasq[1648]: using only locally-known addresses for domain invalid
Sun Jul 12 14:37:54 2020 daemon.info dnsmasq[1648]: using only locally-known addresses for domain bind
Sun Jul 12 14:37:54 2020 daemon.info dnsmasq[1648]: using only locally-known addresses for domain lan
Sun Jul 12 14:37:54 2020 daemon.info dnsmasq[1648]: using nameserver 2404:1a8:7f01:b::3#53
Sun Jul 12 14:37:54 2020 daemon.info dnsmasq[1648]: using nameserver 2404:1a8:7f01:a::3#53
Sun Jul 12 14:37:55 2020 user.notice firewall: Reloading firewall due to ifup of wan6 (eth1)
Sun Jul 12 14:37:55 2020 daemon.notice netifd: Interface 'wan' is now up
Sun Jul 12 14:37:55 2020 daemon.notice netifd: tunnel 'ds-wan' link is up
Sun Jul 12 14:37:55 2020 kern.warn kernel: [ 5268.215807] ip6_tunnel: ds-wan xmit: Local address not yet configured!
Sun Jul 12 14:37:55 2020 user.notice firewall: Reloading firewall due to ifup of wan (ds-wan)
Sun Jul 12 14:37:56 2020 kern.warn kernel: [ 5269.078951] ip6_tunnel: ds-wan xmit: Local address not yet configured!
Sun Jul 12 14:37:57 2020 kern.warn kernel: [ 5269.943691] ip6_tunnel: ds-wan xmit: Local address not yet configured!
Sun Jul 12 14:37:58 2020 kern.warn kernel: [ 5270.806820] ip6_tunnel: ds-wan xmit: Local address not yet configured!
Sun Jul 12 14:37:58 2020 kern.warn kernel: [ 5271.348972] ip6_tunnel: ds-wan xmit: Local address not yet configured!
Sun Jul 12 14:37:58 2020 kern.warn kernel: [ 5271.355927] ip6_tunnel: ds-wan xmit: Local address not yet configured!
Sun Jul 12 14:37:58 2020 kern.warn kernel: [ 5271.381185] ip6_tunnel: ds-wan xmit: Local address not yet configured!
Sun Jul 12 14:37:58 2020 kern.warn kernel: [ 5271.598729] ip6_tunnel: ds-wan xmit: Local address not yet configured!
Sun Jul 12 14:37:58 2020 kern.warn kernel: [ 5271.669228] ip6_tunnel: ds-wan xmit: Local address not yet configured!
--
Sun Jul 12 14:39:24 2020 kern.info kernel: [ 5356.878986] eth1: link down
Sun Jul 12 14:39:24 2020 daemon.notice netifd: Network device 'eth1' link is down
Sun Jul 12 14:39:24 2020 daemon.notice netifd: Interface 'wan6' has link connectivity loss
Sun Jul 12 14:39:24 2020 daemon.notice netifd: wan6 (3511): Command failed: Permission denied
Sun Jul 12 14:39:24 2020 daemon.notice netifd: Interface 'wan6' is now down
Sun Jul 12 14:39:24 2020 daemon.notice netifd: Interface 'wan' has lost the connection
Sun Jul 12 14:39:24 2020 daemon.warn dnsmasq[1648]: no servers found in /tmp/resolv.conf.d/resolv.conf.auto, will retry
Sun Jul 12 14:39:24 2020 daemon.notice netifd: Interface 'wan6' is disabled
Sun Jul 12 14:39:24 2020 daemon.notice netifd: Interface 'wan6' is enabled
Sun Jul 12 14:39:24 2020 daemon.err odhcpd[1081]: Failed to send to ff02::2%wan6@eth1 (Permission denied)
Sun Jul 12 14:39:24 2020 daemon.notice netifd: tunnel 'ds-wan' link is down
Sun Jul 12 14:39:24 2020 daemon.notice netifd: Interface 'wan' is now down
Sun Jul 12 14:39:24 2020 daemon.notice netifd: Interface 'wan' is setting up now
Sun Jul 12 14:39:24 2020 daemon.notice netifd: Interface 'wan' is now down
Sun Jul 12 14:39:26 2020 kern.info kernel: [ 5359.154924] eth1: link up (100Mbps/Full duplex)
Sun Jul 12 14:39:26 2020 daemon.notice netifd: Network device 'eth1' link is up
Sun Jul 12 14:39:26 2020 daemon.notice netifd: Interface 'wan6' has link connectivity
Sun Jul 12 14:39:26 2020 daemon.notice netifd: Interface 'wan6' is setting up now
Sun Jul 12 14:39:26 2020 kern.info kernel: [ 5359.159890] IPv6: ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
Sun Jul 12 14:39:26 2020 daemon.err odhcp6c[3733]: Failed to send RS (Address not available)
Sun Jul 12 14:39:26 2020 daemon.err odhcp6c[3733]: Failed to send DHCPV6 message to ff02::1:2 (Address not available)
Sun Jul 12 14:39:27 2020 daemon.err odhcp6c[3733]: Failed to send DHCPV6 message to ff02::1:2 (Address not available)
Sun Jul 12 14:39:29 2020 daemon.err odhcp6c[3733]: Failed to send DHCPV6 message to ff02::1:2 (Address not available)
Sun Jul 12 14:39:30 2020 daemon.err odhcp6c[3733]: Failed to send RS (Address not available)
Sun Jul 12 14:39:34 2020 daemon.err odhcp6c[3733]: Failed to send DHCPV6 message to ff02::1:2 (Address not available)
Sun Jul 12 14:39:34 2020 daemon.err odhcp6c[3733]: Failed to send RS (Address not available)
Sun Jul 12 14:39:46 2020 daemon.notice netifd: Interface 'wan' is setting up now
Sun Jul 12 14:39:46 2020 daemon.notice netifd: Interface 'wan6' is now up
Sun Jul 12 14:39:46 2020 daemon.info dnsmasq[1648]: reading /tmp/resolv.conf.d/resolv.conf.auto
Sun Jul 12 14:39:46 2020 daemon.info dnsmasq[1648]: using only locally-known addresses for domain test
Sun Jul 12 14:39:46 2020 daemon.info dnsmasq[1648]: using only locally-known addresses for domain onion
Sun Jul 12 14:39:46 2020 daemon.info dnsmasq[1648]: using only locally-known addresses for domain localhost
Sun Jul 12 14:39:46 2020 daemon.info dnsmasq[1648]: using only locally-known addresses for domain local
Sun Jul 12 14:39:46 2020 daemon.info dnsmasq[1648]: using only locally-known addresses for domain invalid
Sun Jul 12 14:39:46 2020 daemon.info dnsmasq[1648]: using only locally-known addresses for domain bind
Sun Jul 12 14:39:46 2020 daemon.info dnsmasq[1648]: using only locally-known addresses for domain lan
Sun Jul 12 14:39:46 2020 daemon.info dnsmasq[1648]: using nameserver 2404:1a8:7f01:b::3#53
Sun Jul 12 14:39:46 2020 daemon.info dnsmasq[1648]: using nameserver 2404:1a8:7f01:a::3#53
Sun Jul 12 14:39:46 2020 user.notice firewall: Reloading firewall due to ifup of wan6 (eth1)
Sun Jul 12 14:39:47 2020 daemon.notice netifd: Interface 'wan' is now up
Sun Jul 12 14:39:47 2020 daemon.notice netifd: tunnel 'ds-wan' link is up
Sun Jul 12 14:39:47 2020 user.notice firewall: Reloading firewall due to ifup of wan (ds-wan)
Sun Jul 12 14:39:47 2020 kern.warn kernel: [ 5380.385444] ip6_tunnel: ds-wan xmit: Local address not yet configured!
Sun Jul 12 14:39:47 2020 kern.warn kernel: [ 5380.616741] ip6_tunnel: ds-wan xmit: Local address not yet configured!
Sun Jul 12 14:39:49 2020 kern.warn kernel: [ 5382.216640] ip6_tunnel: ds-wan xmit: Local address not yet configured!
Sun Jul 12 14:39:53 2020 kern.warn kernel: [ 5386.389067] ip6_tunnel: ds-wan xmit: Local address not yet configured!
Sun Jul 12 14:39:53 2020 kern.warn kernel: [ 5386.396239] ip6_tunnel: ds-wan xmit: Local address not yet configured!
Sun Jul 12 14:39:53 2020 kern.warn kernel: [ 5386.403340] ip6_tunnel: ds-wan xmit: Local address not yet configured!
Sun Jul 12 14:39:56 2020 kern.warn kernel: [ 5389.002663] ip6_tunnel: ds-wan xmit: Local address not yet configured!
Sun Jul 12 14:39:56 2020 kern.warn kernel: [ 5389.257410] ip6_tunnel: ds-wan xmit: Local address not yet configured!
Sun Jul 12 14:39:56 2020 kern.warn kernel: [ 5389.314287] ip6_tunnel: ds-wan xmit: Local address not yet configured!


This task has the following sub-task
ID Project Summary Priority Severity Progress
3280 OpenWrt/LEDE Project FS#3280 - Wan interface and sometimes lan interfaces randomly go up/down a Very Low Critical
0%
Closed by  Chuanhong Guo
11.10.2020 05:00
Reason for closing:  Fixed
Stanislav German-Evtushenko commented on 12.07.2020 06:18

Kernel logs:

[  270.462928] eth1: link down
[  273.310452] eth1: link up (100Mbps/Full duplex)
[  273.316609] IPv6: ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
[  761.753793] eth1: link down
[  764.027453] eth1: link up (100Mbps/Full duplex)
[  764.033121] IPv6: ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
[  786.791642] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[  786.805226] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[  787.614693] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[  787.646373] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[  788.144143] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[  788.432037] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[  788.485928] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 2821.238040] eth1: link down
[ 2823.511539] eth1: link up (100Mbps/Full duplex)
[ 2823.516453] IPv6: ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
[ 2844.695917] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 2847.142196] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 4103.506462] eth1: link down
[ 4105.782348] eth1: link up (100Mbps/Full duplex)
[ 4105.787321] IPv6: ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
[ 4127.330490] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 4127.712988] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 4128.223311] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 4129.508799] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 4129.515926] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 4129.538444] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 4129.757929] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 4129.970986] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 4130.402844] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 4131.267867] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 4131.299211] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 4131.807613] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 4132.127828] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 4133.856708] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 4226.612658] eth1: link down
[ 4229.236067] eth1: link up (100Mbps/Full duplex)
[ 4229.241354] IPv6: ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
[ 4249.285153] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 4250.564523] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 4254.919989] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 5247.087682] eth1: link down
[ 5249.361066] eth1: link up (100Mbps/Full duplex)
[ 5249.366018] IPv6: ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
[ 5268.215807] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 5269.078951] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 5269.943691] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 5270.806820] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 5271.348972] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 5271.355927] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 5271.381185] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 5271.598729] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 5271.669228] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 5271.810157] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 5272.247262] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 5272.748313] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 5272.755443] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 5272.783381] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 5272.986766] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 5273.110961] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 5273.203067] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 5273.398691] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 5273.429838] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 5273.636195] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 5273.975102] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 5274.069709] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 5274.165219] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 5274.467768] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 5274.592683] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 5274.838795] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 5274.939754] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 5275.373899] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 5276.256129] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 5276.565036] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 5276.982705] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 5277.122575] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 5277.976311] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 5278.262048] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 5356.878986] eth1: link down
[ 5359.154924] eth1: link up (100Mbps/Full duplex)
[ 5359.159890] IPv6: ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
[ 5380.385444] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 5380.616741] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 5382.216640] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 5386.389067] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 5386.396239] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 5386.403340] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 5389.002663] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 5389.257410] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 5389.314287] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 5389.321462] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 5389.448061] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 7422.510097] eth1: link down
[ 7424.781559] eth1: link up (100Mbps/Full duplex)
[ 7424.786837] IPv6: ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
[ 7446.628335] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 7449.442524] ip6_tunnel: ds-wan xmit: Local address not yet configured!
[ 7452.516535] ip6_tunnel: ds-wan xmit: Local address not yet configured!
Stanislav German-Evtushenko commented on 12.07.2020 16:30

I have tried the suggestion from here and rebuilt the firmware from the master with commits 3d93b35f03 and 443fc9ac35 reverted. Seems to work well now.

Thiago H Ribeiro commented on 08.08.2020 20:30

I am having the same issue on a DIR-878 (ramips)
I don't know how to build the firmware but I'm an experienced Linux user, gonna research the documentation.
I want to link my troubleshooting history if it's any assistance to anyone searching this issue in the future: Forum thread

Edit: I filed https://bugs.openwrt.org/index.php?do=details&task_id=3280 concerning my issue as the relationship between them is still speculative.

Reiner Otto commented on 11.08.2020 06:53

Same bug on ZBT WE826 (MT7620A) WAN-connection via eth0.2 going up and down.

LinuxKernel1 commented on 21.08.2020 14:00

Had the same problem on WA850RE & WA860RE (OpenWrt 19.07-SNAPSHOT, r11151-afaa978b74).

git revert 3d93b35f03 –no-edit
and
git revert 443fc9ac35 –no-edit
fixed the issue for me.

The link problems were easy to reproduce...just had to generate some higher load (e.g. a download via wifi with about 50 Mbit/s).

Any more information needed to solve this?

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing