OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Enrique Rodriguez - 02.07.2020

FS#3214 - mesh doesn't work on DFS channels on ETSI domain

Device: 2x Yuncore XD4200
OpenWrt version: 19.07.3
Radios: QCA9888 using ath10k-ct driver

Steps to reproduce:

  • Configure the 5GHz radio on a DFS channel using some ETSI regulatory domain (example: ES) on both APs:

/etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11a'
	option path 'pci0000:00/0000:00:00.0'
	option legacy_rates '0'
	option txpower '15'
	option channel '100'
	option htmode 'VHT40'
	option country 'ES'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option mesh_rssi_threshold '0'
	option mesh_fwding '1'
	option mode 'mesh'
	option mesh_id 'TESTMESH'
	option network 'MESH'
	option key '12345678'
	option encryption 'sae'
  • Configure an interface with static AP for the APs:

(AP1) /etc/config/network

config interface 'MESH'
	option proto 'static'
	option ipaddr '192.168.150.10'
	option netmask '255.255.255.0'

(AP2) /etc/config/network

config interface 'MESH'
	option proto 'static'
	option ipaddr '192.168.150.11'
	option netmask '255.255.255.0'
  • Reload wifi on both APs and wait for DFS scan to end

Logread output shows the following errors:

Thu Jul  2 11:32:23 2020 daemon.notice wpa_supplicant[6831]: wlan0: MESH-GROUP-STARTED ssid="TESTMESH" id=0
Thu Jul  2 11:33:24 2020 daemon.notice wpa_supplicant[6831]: wlan0: DFS-CAC-COMPLETED freq=5500 success=1 ht_enabled=1 chan_offset=1 chan_width=2 cf1=5510 cf2=0
Thu Jul  2 11:33:24 2020 daemon.notice wpa_supplicant[6831]: wlan0: interface state DFS->ENABLED
Thu Jul  2 11:33:24 2020 daemon.notice wpa_supplicant[6831]: wlan0: AP-ENABLED
Thu Jul  2 11:33:24 2020 daemon.notice wpa_supplicant[6831]: wlan0: joining mesh TESTMESH
Thu Jul  2 11:33:25 2020 daemon.notice wpa_supplicant[6831]: wlan0: CTRL-EVENT-CONNECTED - Connection to 00:00:00:00:00:00 completed [id=0 id_str=]
Thu Jul  2 11:33:25 2020 daemon.notice netifd: Network device 'wlan0' link is up
Thu Jul  2 11:33:25 2020 daemon.notice netifd: Interface 'MESH' has link connectivity
Thu Jul  2 11:33:25 2020 kern.info kernel: [ 8103.892412] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
Thu Jul  2 11:33:28 2020 daemon.notice wpa_supplicant[6831]: wlan0: new peer notification for aa:bb:cc:dd:ee:ff
Thu Jul  2 11:33:28 2020 daemon.notice wpa_supplicant[6831]: wlan0: Mesh MPM: failed to send peering frame
Thu Jul  2 11:33:28 2020 daemon.notice wpa_supplicant[6831]: wlan0: Mesh MPM: failed to send peering frame
Thu Jul  2 11:33:29 2020 daemon.notice wpa_supplicant[6831]: wlan0: Mesh MPM: failed to send peering frame
Thu Jul  2 11:33:29 2020 daemon.notice wpa_supplicant[6831]: wlan0: Mesh MPM: failed to send peering frame
Thu Jul  2 11:33:29 2020 daemon.notice wpa_supplicant[6831]: wlan0: new peer notification for aa:bb:cc:dd:ee:ff
Thu Jul  2 11:33:29 2020 daemon.notice wpa_supplicant[6831]: wlan0: Mesh MPM: failed to send peering frame
Thu Jul  2 11:33:29 2020 daemon.notice wpa_supplicant[6831]: wlan0: Mesh MPM: failed to send peering frame
Thu Jul  2 11:33:29 2020 daemon.notice wpa_supplicant[6831]: wlan0: Mesh MPM: failed to send peering frame
Thu Jul  2 11:33:29 2020 daemon.notice wpa_supplicant[6831]: wlan0: Mesh MPM: failed to send peering frame
Thu Jul  2 11:33:29 2020 daemon.notice wpa_supplicant[6831]: wlan0: new peer notification for aa:bb:cc:dd:ee:ff
Thu Jul  2 11:33:29 2020 daemon.notice wpa_supplicant[6831]: wlan0: Mesh MPM: failed to send peering frame
Thu Jul  2 11:33:29 2020 daemon.notice wpa_supplicant[6831]: wlan0: Mesh MPM: failed to send peering frame
Thu Jul  2 11:33:29 2020 daemon.notice wpa_supplicant[6831]: wlan0: Mesh MPM: failed to send peering frame
Thu Jul  2 11:33:29 2020 daemon.notice wpa_supplicant[6831]: wlan0: Mesh MPM: failed to send peering frame
Thu Jul  2 11:33:29 2020 daemon.notice wpa_supplicant[6831]: wlan0: new peer notification for aa:bb:cc:dd:ee:ff
Thu Jul  2 11:33:29 2020 daemon.notice wpa_supplicant[6831]: wlan0: Mesh MPM: failed to send peering frame
Thu Jul  2 11:33:29 2020 daemon.notice wpa_supplicant[6831]: wlan0: Mesh MPM: failed to send peering frame
Thu Jul  2 11:33:29 2020 daemon.notice wpa_supplicant[6831]: wlan0: Mesh MPM: failed to send peering frame
Thu Jul  2 11:33:29 2020 daemon.notice wpa_supplicant[6831]: wlan0: Mesh MPM: failed to send peering frame
Thu Jul  2 11:33:29 2020 daemon.notice wpa_supplicant[6831]: wlan0: new peer notification for aa:bb:cc:dd:ee:ff
Thu Jul  2 11:33:30 2020 daemon.notice wpa_supplicant[6831]: wlan0: Mesh MPM: failed to send peering frame
Thu Jul  2 11:33:30 2020 daemon.notice wpa_supplicant[6831]: wlan0: Mesh MPM: failed to send peering frame
Thu Jul  2 11:33:30 2020 daemon.notice wpa_supplicant[6831]: wlan0: Mesh MPM: failed to send peering frame
Thu Jul  2 11:33:30 2020 daemon.notice wpa_supplicant[6831]: wlan0: Mesh MPM: failed to send peering frame

In this scenario, an user is unable to connect to the MESH peer.

Note: if you change the radio regulatory domain to a non-ETSI (example: US), it works correctly

This hostapd patch appears to be the root problem cause:

  • package/network/services/hostapd/patches/015-mesh-do-not-use-offchan-mgmt-tx-on-DFS.patch

(previous versions of this patch disallowed offchannel tx for all DFS domains, not only for non-ETSI)

Project Manager
Daniel Golle commented on 23.07.2020 17:46

Please retry with building from my staging tree where I have replaced the old mesh-DFS patcheset from 2018 with a more recent rework submitted to hostap's mailing list recently. Chances for this to work are definitely higher, but I don't have resources to test this atm.

https://git.openwrt.org/openwrt/staging/dangole.git

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing