OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Kernel
  • Assigned To No-one
  • Operating System All
  • Severity Critical
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by valdisk - 30.06.2020

FS#3211 - wrt1200ac issue with mvneta driver in 5.4 kernel - interface not found

wrt1200ac works OK with 4.19.108 kernel. eth1 is the upstream port, eth0 is the 4 local gigabit ports. dmesg reports:

[ 1.098981] 0×000000280000-0×000000900000 : “unused_area” [ 1.105081] libphy: Fixed MDIO Bus: probed
[ 1.109546] libphy: orion_mdio_bus: probed
[ 1.113853] mvneta_bm f10c8000.bm: Buffer Manager for network controller enabled
[ 1.122882] mvneta f1070000.ethernet eth0: Using hardware mac address c0:56:27:70:5b:65
[ 1.132447] mvneta f1034000.ethernet eth1: Using random mac address 9e:2e:40:0f:3a:63
[ 1.140510] ehci_hcd: USB 2.0 ‘Enhanced’ Host Controller (EHCI) Driver
[ 1.147081] ehci-pci: EHCI PCI platform driver
[ 1.151575] ehci-platform: EHCI generic platform driver
[ 1.156913] ehci-orion: EHCI orion driver
[ 1.161040] orion-ehci f1058000.usb: EHCI Host Controller

Under the 5.4.48 kernel, eth1 doesn’t show up, so no upstream connectivity.

[ 1.208713] orion-mdio f1072004.mdio: IRQ index 0 not found
[ 1.214360] libphy: orion_mdio_bus: probed
[ 1.218622] mv88e6085 f1072004.mdio-mii:00: switch 0×1760 detected: Marvell 88E6176, revision 1
[ 1.389672] libphy: mv88e6xxx SMI: probed
[ 1.395805] mvneta_bm f10c8000.bm: Buffer Manager for network controller enabled
[ 1.404784] mvneta f1070000.ethernet eth0: Using hardware mac address c0:56:27:70:5b:65
[ 1.412919] ehci_hcd: USB 2.0 ‘Enhanced’ Host Controller (EHCI) Driver
[ 1.419511] ehci-pci: EHCI PCI platform driver
[ 1.424011] ehci-platform: EHCI generic platform driver
[ 1.429356] ehci-orion: EHCI orion driver
[ 1.433476] orion-ehci f1058000.usb: EHCI Host Controller


anomeome commented on 01.07.2020 01:33

This is expected with the change from swconfig to DSA.

valdisk commented on 02.07.2020 06:12

Thanks for that info. Is there a relevant issue to track so I know when it's at least plausibly worth trying again? (I don't mind testing bleeding-edge software, but it's not worth the effort until it gets to "needs sysadmin to apply crowbar to the config" levels of working...)

anomeome commented on 02.07.2020 16:53

It works now, but your have to adapt you config for DSA. FS3171, or PR2942 for a more complex vlan setup, also the forum has more examples.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing