OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Packages
  • Assigned To
    Yousong Zhou
  • Operating System All
  • Severity High
  • Priority Very Low
  • Reported Version openwrt-19.07
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Francis - 18.06.2020
Last edited by Baptiste Jonglez - 28.09.2020

FS#3191 - L2TP 19.07.3 interface is not showing

- Device problem occurs on

Tested on both

TP-Link TL-WDR3600 v1 ath79
MikroTik RB750r2 ar71xx

- Software versions of OpenWrt/LEDE release, packages, etc.

Tried to install the following packages;

kmod-l2tp
kmod-l2tp-eth
kmod-l2tp-ip
kmod-pppol2tp
xl2tpd
luci-proto-ppp

- Steps to reproduce

when trying to add a new interface is not there nor dos it not show.

Im not trying to setup a VPN as my ISP UK AAISP is offering this service https://www.aa.net.uk/broadband/l2tp-service

Closed by  Baptiste Jonglez
28.09.2020 21:41
Reason for closing:  Not a bug
Project Manager
Yousong Zhou commented on 24.07.2020 05:06

Last time we saw this it's because netifd needs to be restarted to load the just installed proto handler. This can be achieved by network restart or reboot. Is it possible that this is the same issue?

James White commented on 23.08.2020 10:39

I was recently deploying AAISP L2TP as well, make sure you've allocated your IPs on the AAISP end as this was the reason why my L2TP interface was not visible and coming up properly even after a reboot to load the l2tp kmods.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing