OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity High
  • Priority Very Low
  • Reported Version All
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Justin F - 12.06.2020

FS#3176 - pi zero AP+STA mode does not work

Supply the following if possible:
- device: Raspberry Pi Zero W
- Versions confirmed on: recent Snapshot, 19.07.3, 18.06.8, 17.01.4
- Steps to reproduce:

  1. flash image to sd card, put sd card into pi
  2. turn on wifi radio (uci set wireless.radio0.disabled=0)
  3. add a wireless network such that one is a station and one is a AP (I’ve tried though gui and command line)
  4. restart wifi (either through reboot or wifi command)
  5. Now in the dmesg you can see wlan0-1 cycling between blocking forwarding and disabled states

Additional info:
I made this forum post about it, but not much has come from that and I’ve learned a lot since posting.

I know that this mode is supported from the iw list output -

 valid interface combinations:
                 * #{ managed } <= 1, #{ P2P-device } <= 1, #{ P2P-client, P2P-GO } <= 1,
                   total <= 3, #channels <= 2
                 * #{ managed } <= 1, #{ AP } <= 1, #{ P2P-client } <= 1, #{ P2P-device } <= 1,
                   total <= 4, #channels <= 1
        Supported extended features:
                * [ 4WAY_HANDSHAKE_STA_PSK ]: 4-way handshake with PSK in station mode
                * [ 4WAY_HANDSHAKE_STA_1X ]: 4-way handshake with 802.1X in station mode

I’ve even gotten AP+STA mode to work by manually starting a second instance of hostapd (note that im not killing the original one), but that makes it even more confusing that it doesn’t work normally.

I make sure that they are on the same channel.

If you need anything cleared up please let me know. I’ve tried for over a week now to fix this myself to no avail.

Justin F commented on 23.06.2020 18:45

I believe the issue has to do with the control interfaces used by hostapd and wpa_supplicant.

In 19.07.3 I found that if I edited /lib/netifd/ such that it starts wpa_supplicant without -H /var/run/hostapd/wlan0-1 at the end, it will work.

this was done by commenting out the line containing "$@" and getting rid of the backslash on the above line


Available keyboard shortcuts


Task Details

Task Editing