OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity High
  • Priority Very Low
  • Reported Version openwrt-19.07
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by sunshinejnjn - 03.06.2020

FS#3147 - 802.11w settings on LUCI WIFI page doesn't work properly and causes serious connection problems

Host device

Device problem occurs on: Phicomm PSG1218A (MTK7620, 64M, 8MB, 802.11AC+N)
Software versions of OpenWrt/LEDE release: OpenWRT 19.07.3 Stable (r11063-85e04e9f46 / LuCI openwrt-19.07 branch git-20.136.49537-fb2f363)
Package: wpad-openssl OR hostapd-openssl

External server/service

RADIUS server: Windows Server 2019 NPAS, worked fine with WPA2-EAP

Client

Client WIFI chip and driver: Intel Dual Band Wireless-AC 8265 running newest driver version 20.70.16.4 (driver date: 01/01/2020)

Steps to reproduce:

1. initialize default settings, then remove wpad-basic and install wpad-openssl OR hostapd-openssl to enable WPA3 AP mode
2. leave 802.11w to default setting which is “Required” 3. set country setting, ssid, and etc. as required such as radius for EAP
4 if use WPA2-PSK or WPA2-EAP with default settings, everything works fine.

5. switch WIFI (AC/N) to WPA2-PSK/WPA3-SAE mixed mode (sae+ccmp or something like that) OR WPA2-EAP/WPA3-EAP mixed mode (wpa3-mixed+ccmp or something like that)
6. apply settings wait until effective or reboot to take effect

6.1 __ssid won't come up on 802.11g/n interface__ if in PSK/SAE mixed mode.

7. Client (Intel 8265) won’t be able to connect to SSID,

7.1 if ssid would come up (802.11a/ac), it would be seen on client scan, but the client (Intel 8265) won't be able to connect to SSID, reports "Can't connect", in EAP mode, router side log "Deauthenticated due to local request" after "EAP-SUCCESS"

8. switch 802.11w to other settings, including “Optional”, problem remains, router config file /etc/config/wireless would list “option ieee80211w ‘1’” 9. switch 802.11w to other settings, including “Optional”, problem still remains, router config file /etc/config/wireless will be missing the “option ieee80211w” completely, and it seems wpad or hostapd would assume “optional” (code ‘1’) as default value instead of the documented “disabled” (code ‘0’).

Steps to workaround:

Manually set “option ieee80211w ‘0’” in /etc/config/wireless to disable 802.11w and don’t update settings through LUCI on the problematic ssid, restart wifi. Everything would work.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing