OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Kernel
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Cristian Morales Vega - 13.05.2020

FS#3094 - ath9k on Archer C7 v5 can't see packets (at least in monitor mode) that it can see on Archer C7 v2

On an Archer C7 v5 running OpenWrt SNAPSHOT, r13223-fdd968d64e from https://downloads.openwrt.org/snapshots/targets/ath79/generic/openwrt-ath79-generic-tplink_archer-c7-v5-squashfs-sysupgrade.bin running

iw dev wlan1 set type monitor
ip link set dev wlan1 up
iw dev wlan1 set freq 2462 20
echo 0 > /proc/sys/net/core/bpf_jit_enable (because of FS#3045)
tcpdump -i wlan1 ‘type data and (wlan addr1 <my_pc_wifi_mac> or wlan addr2 <my_pc_wifi_mac>)’

results in an output similar to

11:41:33.012568 162711776us tsft 1.0 Mb/s 2462 MHz 11b -5dBm signal -9dBm signal antenna 0 -7dBm signal antenna 1 -23dBm signal antenna 2 
11:41:33.060509 162759694us tsft 1.0 Mb/s 2462 MHz 11b -5dBm signal -9dBm signal antenna 0 -8dBm signal antenna 1 -25dBm signal antenna 2 
11:41:33.218174 162917394us tsft 1.0 Mb/s 2462 MHz 11b -5dBm signal -12dBm signal antenna 0 -6dBm signal antenna 1 -23dBm signal antenna 2 
11:41:33.266511 162965721us tsft 1.0 Mb/s 2462 MHz 11b -5dBm signal -9dBm signal antenna 0 -7dBm signal antenna 1 -25dBm signal antenna 2 
11:41:33.424343 163123553us tsft 1.0 Mb/s 2462 MHz 11b -6dBm signal -12dBm signal antenna 0 -7dBm signal antenna 1 -24dBm signal antenna 2 
11:41:33.472731 163171934us tsft 1.0 Mb/s 2462 MHz 11b -5dBm signal -10dBm signal antenna 0 -6dBm signal antenna 1 -23dBm signal antenna 2 
11:41:33.630567 163329780us tsft 1.0 Mb/s 2462 MHz 11b -5dBm signal -8dBm signal antenna 0 -8dBm signal antenna 1 -25dBm signal antenna 2 
11:41:33.679703 163378897us tsft 1.0 Mb/s 2462 MHz 11b -5dBm signal -8dBm signal antenna 0 -8dBm signal antenna 1 -25dBm signal antenna 2 

(so only 1.0 Mb/s packets)

Even when doing a big download from my computer.

The same problem happens with 18.06.0-rc1, the first build available with support for this model, and with 19.07.2.

When doing the same with an Archer C7 v2 the problem disappears, with an output more similar to

11:59:34.954388 114503209us tsft 2462 MHz 11n -25dBm signal 144.4 Mb/s MCS 15 20 MHz short GI RX-STBC0 -31dBm signal antenna 0 -32dBm signal antenna 1 -28dBm signal antenna 2 Data IV:35e4 Pad 20 KeyID 0
11:59:34.957163 114505988us tsft 2462 MHz 11n -25dBm signal 144.4 Mb/s MCS 15 20 MHz short GI RX-STBC0 -30dBm signal antenna 0 -32dBm signal antenna 1 -27dBm signal antenna 2 Data IV:35f0 Pad 20 KeyID 0
11:59:34.962798 114511615us tsft 2462 MHz 11n -23dBm signal 144.4 Mb/s MCS 15 20 MHz short GI RX-STBC0 -31dBm signal antenna 0 -31dBm signal antenna 1 -24dBm signal antenna 2 Data IV:3608 Pad 20 KeyID 0
11:59:34.970945 114519766us tsft 2462 MHz 11n -24dBm signal 144.4 Mb/s MCS 15 20 MHz short GI RX-STBC0 -30dBm signal antenna 0 -32dBm signal antenna 1 -27dBm signal antenna 2 Data IV:362e Pad 20 KeyID 0
11:59:34.977293 114526117us tsft 2462 MHz 11n -23dBm signal 144.4 Mb/s MCS 15 20 MHz short GI RX-STBC0 -33dBm signal antenna 0 -32dBm signal antenna 1 -24dBm signal antenna 2 Data IV:364a Pad 20 KeyID 0
11:59:34.977943 114526561us tsft 2462 MHz 11n -25dBm signal 144.4 Mb/s MCS 15 20 MHz short GI RX-STBC0 -30dBm signal antenna 0 -33dBm signal antenna 1 -27dBm signal antenna 2 Data IV:364c Pad 20 KeyID 0
11:59:34.978148 114527006us tsft 2462 MHz 11n -25dBm signal 144.4 Mb/s MCS 15 20 MHz short GI RX-STBC0 -31dBm signal antenna 0 -33dBm signal antenna 1 -27dBm signal antenna 2 Data IV:364d Pad 20 KeyID 0
11:59:34.979699 114528418us tsft 2462 MHz 11n -24dBm signal 144.4 Mb/s MCS 15 20 MHz short GI RX-STBC0 -31dBm signal antenna 0 -32dBm signal antenna 1 -26dBm signal antenna 2 Data IV:3654 Pad 20 KeyID 0
11:59:34.980137 114528862us tsft 2462 MHz 11n -25dBm signal 144.4 Mb/s MCS 15 20 MHz short GI RX-STBC0 -31dBm signal antenna 0 -32dBm signal antenna 1 -27dBm signal antenna 2 Data IV:3656 Pad 20 KeyID 0
11:59:34.980937 114529750us tsft 2462 MHz 11n -25dBm signal 144.4 Mb/s MCS 15 20 MHz short GI RX-STBC0 -34dBm signal antenna 0 -32dBm signal antenna 1 -27dBm signal antenna 2 Data IV:365a Pad 20 KeyID 0
11:59:34.986293 114535116us tsft 2462 MHz 11n -25dBm signal 144.4 Mb/s MCS 15 20 MHz short GI RX-STBC0 -34dBm signal antenna 0 -31dBm signal antenna 1 -27dBm signal antenna 2 Data IV:3672 Pad 20 KeyID 0
11:59:34.996568 114545388us tsft 2462 MHz 11n -25dBm signal 144.4 Mb/s MCS 15 20 MHz short GI RX-STBC0 -30dBm signal antenna 0 -33dBm signal antenna 1 -27dBm signal antenna 2 Data IV:36a0 Pad 20 KeyID 0
11:59:34.997799 114546639us tsft 2462 MHz 11n -24dBm signal 144.4 Mb/s MCS 15 20 MHz short GI RX-STBC0 -31dBm signal antenna 0 -31dBm signal antenna 1 -27dBm signal antenna 2 Data IV:36a4 Pad 20 KeyID 0
11:59:35.000680 114549501us tsft 2462 MHz 11n -25dBm signal 144.4 Mb/s MCS 15 20 MHz short GI RX-STBC0 -31dBm signal antenna 0 -31dBm signal antenna 1 -27dBm signal antenna 2 Data IV:36b2 Pad 20 KeyID 0
11:59:35.004352 114553174us tsft 2462 MHz 11n -24dBm signal 144.4 Mb/s MCS 15 20 MHz short GI RX-STBC0 -31dBm signal antenna 0 -32dBm signal antenna 1 -26dBm signal antenna 2 Data IV:36c2 Pad 20 KeyID 0

The timestamps show different times because I was trying to reproduce it with something as close as possible to a fresh flashing and I couldn’t access both devices at the same time as routers. But I have actually reproduced this making both devices capture traffic at the same time after messing a bit with their network configurations.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing