OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Kernel
  • Assigned To No-one
  • Operating System All
  • Severity High
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by n8v8R - 09.05.2020
Last edited by Petr Štetiar - 17.06.2020

FS#3084 - [netfilter] flow table disabled due to unset and missing kconf

With https://git.openwrt.org/?p=openwrt/openwrt.git;a=blob;f=target/linux/generic/config-5.4;h=cdee4c973b2d6a642dadff38a95ec45b309c2dc2;hb=refs/heads/master#l3657

CONFIG_NF_FLOW_TABLE is not set

there is no support for flow tables.

Also from upstream source https://github.com/torvalds/linux/blob/v5.4/net/netfilter/Kconfig#L696 it appears that

NF_FLOW_TABLE_INET

is missing downstream.

Closed by  Petr ┼átetiar
17.06.2020 08:11
Reason for closing:  Not a bug
Additional comments about closing:  

Requested.

Etienne CHAMPETIER commented on 10.05.2020 17:50

flow offload is built as modules and is in kmod-nf-flow package or am I missing something ?

n8v8R commented on 10.05.2020 18:23

Something that is target specific then? The generic kconf is unset however (and therefore could not build as module) and the other kconf is absent.

Oddly https://github.com/openwrt/openwrt/blob/master/package/kernel/linux/modules/netfilter.mk#L154 has

CONFIG_NF_FLOW_TABLE_HW

which though is not a valid kconf in upstream's 5.4 source code.

n8v8R commented on 12.06.2020 17:30

Tested with

{"kernel":"5.4.45","hostname":"OpenWrt","system":"ARMv7 Processor rev 1 (v7l)","model":"Turris Omnia","board_name":"cznic,turris-omnia","release":{"distribution":"OpenWrt","version":"SNAPSHOT","revision":"r13552-cd09f26660","target":"mvebu/cortexa9","description":"OpenWrt SNAPSHOT r13552-cd09f26660"}}

xzgrep NF_FLOW_TABLE /proc/config.gz
CONFIG_NF_FLOW_TABLE_INET=m
CONFIG_NF_FLOW_TABLE=m
CONFIG_NF_FLOW_TABLE_HW=m
CONFIG_NF_FLOW_TABLE_IPV4=m
CONFIG_NF_FLOW_TABLE_IPV6=m

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing