OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity High
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by txt.file - 08.05.2020

FS#3072 - Samknows WhiteBox8 misses 2.4 GHz pcie wireless NIC

device

software versions

tested & misses 2.4 GHz NIC

tested & has 2.4 GHz NIC

reproduce

  • build OpenWrt master branch with a given commits and flash it on the device (my build config is attached)
  • run “iw dev” or “iw list”
    • in problem state it lists one interface (the 5 GHz wireless NIC)
    • in good state it lists two interfaces (2.4 GHz and 5 GHz wireless NIC)

conclusion

I think it has either to do with ramips: mt7621: switch kernel version to 5.4 or with ramips: mt7621: update PCIe node in dtsi. Between the known good and earliest known bad commit are multiple commits working together. I fear to test them one by one.

txt.file commented on 08.05.2020 15:38

I tested further e714cf4195b5798f40a3442c01233ce4783ef0ad is also working. So my initial conclusion is wrong.

txt.file commented on 08.05.2020 16:50

tested as bad 82df192a010418fac9c4db440490290f55f7e157

If my manual bisect is correct I am down to 10 possible commits between working and broken.

txt.file commented on 08.05.2020 23:28

Can't reproduce it in a constant way. Sometimes PCIe1 is present. Sometimes it is not present. Maybe this is just a hardware issue on my device. I don't know. Kind of strange.

txt.file commented on 13.05.2020 10:41

compiled r13225-bc0288b768, flashed it via TFTP and issue is present

flashing via "sysupgrade -n image.bin" has the same output

txt.file commented on 14.05.2020 12:28

compiled r13235-eb17ee294c (update to linux 5.4.41), flashed via TFTP and issue is present

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing