OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Base system
  • Assigned To
    Chuanhong Guo
  • Operating System All
  • Severity High
  • Priority Very Low
  • Reported Version openwrt-19.07
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Tai - 27.04.2020
Last edited by Chuanhong Guo - 28.04.2020

FS#3053 - ZBT WE3526 256MB Variant Soft Bricks Because of ZBT-WE3526.dts

This was solved by changing /openwrt/target/linux/ramips/dts/ZBT-WE3526.dts

line #14 from

reg = <0×0 0x1c000000>, <0×20000000 0×4000000>;

to

reg = <0×0 0×10000000>;

After building an image with these changes the 256MB Variant of the WE3526 would work.

To reproduce the problem on 256MB Variant I tried building the image with reg = <0×0 0x1c000000>, <0×20000000 0×4000000>; (which is basically no change). I would get stuck in the soft brick.

I discovered this solution because of this commit https://github.com/openwrt/openwrt/commit/310f851bd916426cae25f5883303f0479e8f407b

The problems with the 256MB Variant may be because of https://github.com/openwrt/openwrt/pull/2220 where memory auto-detection for mt7621 is not reading the 256MB correctly. Might be worth investigating.

Reference Post From When I Had the Problem: https://forum.openwrt.org/t/zbt-we3526-soft-bricks-everytime-256mb-ram-variant/61913/2

Fixing this will solve soft bricks for WE3526 256MB Routers.

Closed by  Chuanhong Guo
28.04.2020 03:06
Reason for closing:  Fixed
Additional comments about closing:  

fixed in https://git.o penwrt.org/?p=openwrt/openwrt.git;a=comm it;h=5feb0df9bb3bd83ec49af17d2abc261fc58 e2551

Tai commented on 27.04.2020 17:23

@981213 gch981213@gmail.com has fixed this in commit https://git.openwrt.org/1e0bbd0ce766d5

Thread: https://github.com/openwrt/openwrt/pull/2220

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing