OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity High
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Edward Arreza - 26.04.2020

FS#3048 - Kernel 5.4 no wan connection on Netgear R6850

Affected Device - Netgear R6850

Software Versions:
1. Master commit 4c70bb4f906b875aee1da6636aa7d2023ef69064 or latest commit.
2. Luci
3. Luci-app-adblock, luci-app-upnp, luci-app-sqm, luci-app-wol, luci-app-openvpn

Issue:
1. Ever since kernel updated to 5.4, wan interface doesn’t get IPs.
2. Kernel logs doesn’t show error and even shows wan interface is up.
3. Sometimes it would get IP if I would restart /etc/init.d/network.
4. Currently reverted back to kernel 4.14 commit id: b51ea43f900191bc8ce7411dad39239fac6df4f8 and commit message: bcm53xx: refactor board.d code in 02_network

Step to reproduce:
1. Compile latest commit including following packages: luci-core, luci-app-adblock, luci-app-upnp, luci-app-sqm, etc.
1. Flash firmware and do not retain settings to latest commit.
2. Login to router via ssh. Then do cat /etc/config/network
3. Interface ‘wan’ ‘ipaddr’ is empty. ‘ifname’ is set to ‘wan’. ‘proto’ set to dhcp.
4. Set to static and input modem ip addresses manually. Then restart network. Unable to connect to modem gui.
5. Also try to set modem to bridge mode and the openwrt router to PPPoE - No IP.
6. Added ‘forcelink: 1’ then restarted network to no avail.
7. Restarting network might establish connection but when you restart network or router again, there will be no connection. Until you restart network until you get IP addresses.

PS: Can provide detailed logs if requested as I am back to kernel 4.14.172 commit. Since this router serves as gateway to our home internet with multiple clients.

Edward Arreza commented on 26.04.2020 10:52

Update:
I compiled latest git commit again. However I discovered a workaround of not getting IPs on WAN even after reboot.
I decided to setup WAN via Luci instead. Obviously I would get "Connection Attempt Error" on PPPOE or blank IP address when on DHCP or Static mode. Even if I rebooted the router it would be the case.

Until I changed the physical interface of the WAN to eth0 instead of 'wan' until I get an error via Luci interface. Once I get the error "Connection attempt error", I would switch the physical interface back to 'wan' interface and I got a connection.

I did another reboot to try my workaround. This time it took like around 4 attempts of switch the physical interface until I get an IP on the WAN interface.

Attached are the following:
1. Kernel Log of the current state of the router.
2. System Log of the current state of the router.
3. Kernel Log of when I was on kernel 4.14.172 (commit before 5.4 on mediatek devices) which is the last working commit.

Marcin Gordziejewski commented on 28.04.2020 13:40

I'm having same issue on Asus RT-AC85P which seems to be same processor as yours. I choose to keep settings when flashing the new image - might that be a reason? Did you wipe yours when applying new firmware?

Edward Arreza commented on 28.04.2020 15:20

Hey!

The first time I compiled the new commit, coming from 4.14.172, I have upgraded it to keep the settings before flashing it. I realized maybe the commits meant mediatek devices as I assumed that my device was still under ramips. Right now it's under Mediatek MIPS.

Keeping the settings will make me not able to connect to the router using LAN connections. Only via WiFi 2.4G and 5G.

So had to grab a laptop and revert the router to my previously compiled firmware to boot and tried again. This time by flashing it without retaining any settings since I saw the Kernel is now 5.4.x. I am now able to connect via luci and ssh to the router, however WAN is not working correctly.

I figured a workaround that might have fixed it, which is via luci (since I was only able to re-produce it there), is to change the physical wan interface to something else like eth0. Wait 1 minute then revert it back to WAN interface.

Had to do it atleast 3 times for it to work. DHCP, Static and PPPoE were the ones I tested. Works even after you restart the router. You just have to keep on doing those steps until you get an IP (PPPoE and DHCP) or Static IP is pingable. Currently on my 2nd day with kernel 5.4.35 and rebooted it twice already.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing