OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Critical
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Tommie Mademark - 10.04.2020
Last edited by Adrian Schmutzler - 15.04.2020

FS#2989 - Boots but no connection can be made to router

Hardware: ZBT WG3526 16MB RAM
Image file: openwrt-ramips-mt7621-zbtlink_zbt-wg3526-16m-squashfs-sysupgrade.bin
Image Date Stamp: Snapshot Fri Apr 10 06:55:59 2020

Issue: Flashes without issues.

		Boots but no connection can be made to router using web browser I/F, WinSCP or PuTTY.
		Not responding to ping 192.168.1.1.
		All LAN and WAN ports LED's are flashing.
		No Internet connection (WAN)
Tommie Mademark commented on 12.04.2020 17:58

2020-05-01:
I have now compiled my own image for Zbtlink ZBT-WG3526 (16M)
OpenWrt SNAPSHOT r13136-ad27c133eb / LuCI Master git-20.121.45559-a573da0
Kernel Version 5.4.36
All works fine with a number of extra packages added to the build.
Looks like there might be an issue with your snapshot builds.
*

The issue remains with snapshot build dated "Thu Apr 30 07:24:28 2020"
The issue remains with snapshot build dated "Mon Apr 20 04:54:13 2020".
The issue remains with snapshot build dated "Sun Apr 19 07:38:55 2020".
The issue remains with snapshot build dated "Sat Apr 18 09:08:34 2020".
The issue remains with snapshot build dated "Wed Apr 15 16:57:41 2020".
The issue remains with snapshot build dated "Tue Apr 14 19:02:13 2020".
The issue remains with snapshot build dated "Sun Apr 12 18:20:31 2020".

Every time I run into the issue with flashing the latest snapshot, which I do every time ther's a new image available, even if I can see the image file is of the wrong size, I can always recover by flashing the latest stable release which currently is 19.07.2.

I've encountered this issue several times before over the past year and it can be spotted by looking at the size of the image file. Image files that do not work on my 16MB FLASH version of the ZBT-WG3526, always has the same image file size as the 32 MB FLASH version of the router! If you look at the snapshot files dated "Sun Apr 12 18:20:31 2020" for the 16 MB and compared it to the 32 MB version, they are identical in size. The 32 MB version will install but will not run.

A working image file for the ZBT-WG3526 (16M) apears to have a size of 4 718 784 to 4 718 881 bytes. Below is a list of released versions of image files for ZBT-WG3526 (16M):

2019-02-03 15:10 4 718 784 openwrt-18.06.2-ramips-mt7621-zbt-wg3526-16M-squashfs-sysupgrade.bin
2019-08-16 11:57 4 718 784 openwrt-18.06.4-ramips-mt7621-zbt-wg3526-16M-squashfs-sysupgrade.bin
2019-12-28 16:01 4 718 784 openwrt-18.06.5-ramips-mt7621-zbt-wg3526-16M-squashfs-sysupgrade.bin
2020-03-09 01:21 4 718 784 openwrt-18.06.8-ramips-mt7621-zbt-wg3526-16M-squashfs-sysupgrade.bin
2020-03-30 19:29 4 718 881 openwrt-19.07.2-ramips-mt7621-zbt-wg3526-16M-squashfs-sysupgrade.bin

Todays image file for the 16 MB version is identical in size compared with the 32 MB version:

2020-04-12 18:38 5 243 203 openwrt-ramips-mt7621-zbtlink_zbt-wg3526-16m-squashfs-sysupgrade.bin

camel commented on 22.06.2020 19:16

is it possible to find out on which day the size was increased ? - maybe that would help to tell to DEVS and to do a rollback of that change .... ?

Tommie Mademark commented on 23.06.2020 14:29

The latest stable release is 4608.3 KB in size and is dated Sun May 17, 2020. This image works fine. This date is later than the date I first encountered the problem. By using the config.buildinfo files from releases/19.07.3/targets/ramips/mt7621/ and snapshots/targets/ramips/mt7621/, whoever makes the .config file should be able to figure out what is wrong.

I did a file diff and the first few lines can be seen in the attached screen dump.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing