OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Build Failure
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Critical
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by hngsvtdu@sharklasers.com - 22.11.2016
Last edited by Mathias Kresin - 25.11.2016

FS#297 - Build failure with latest git when building for lantiq

Building latest git code fails.
Git/commit version: d2b79e4d808add264d22e284fa21dfa155e52f05

Anonymized (username) build log:
...
#
# configuration written to .config
#
* Default configuration is based on ‘sandbox_defconfig’ make[4]: Leaving directory ‘/home/user/lede/source/build_dir/host/u-boot-2014.10’ make -C /home/user/lede/source/build_dir/host/u-boot-2014.10 tools-only HOSTCFLAGS=”-I/home/user/lede/source/staging_dir/host/include -I/home/user/lede/source/staging_dir/host/usr/include -O2 -I/home/user/lede/source/staging_dir/host/include -I/home/user/lede/source/staging_dir/host/usr/include " HOSTLDFLAGS=”-L/home/user/lede/source/staging_dir/host/lib -L/home/user/lede/source/staging_dir/host/usr/lib "
make[4]: Entering directory ‘/home/user/lede/source/build_dir/host/u-boot-2014.10’ scripts/kconfig/conf –silentoldconfig Kconfig
CHK include/config.h
GEN include/autoconf.mk
GEN include/autoconf.mk.dep
make[4]: sdl-config: Command not found
make[4]: sdl-config: Command not found
make[4]: sdl-config: Command not found
CHK include/config/uboot.release
make[4]: sdl-config: Command not found
CHK include/generated/version_autogenerated.h
make[4]: sdl-config: Command not found
CHK include/generated/timestamp_autogenerated.h
UPD include/generated/timestamp_autogenerated.h
make[4]: sdl-config: Command not found
HOSTCC tools/img2srec
In file included from /home/user/lede/source/build_dir/host/u-boot-2014.10/include/compiler.h:46:0,
from /home/user/lede/source/build_dir/host/u-boot-2014.10/include/libfdt_env.h:12,
from <command-line>:0:
/home/user/lede/source/staging_dir/host/include/byteswap.h:2:2: warning: #include_next is a GCC extension
#include_next <byteswap.h>
^~~~~~~~~~~~
HOSTCC tools/aisimage.o
HOSTCC tools/atmelimage.o
HOSTCC tools/common/bootm.o
HOSTCC tools/common/image-fit.o
HOSTCC tools/common/image-sig.o
HOSTCC tools/common/image.o
HOSTCC tools/default_image.o
HOSTCC tools/dumpimage.o
HOSTCC tools/fit_check_sign.o
HOSTCC tools/fit_common.o
HOSTCC tools/fit_image.o
HOSTCC tools/fit_info.o
HOSTCC tools/gpimage-common.o
HOSTCC tools/gpimage.o
HOSTCC tools/image-host.o
HOSTCC tools/imagetool.o
HOSTCC tools/imximage.o
HOSTCC tools/kwbimage.o
HOSTCC tools/lib/crc32.o
In file included from /home/user/lede/source/build_dir/host/u-boot-2014.10/include/compiler.h:46:0,
from /home/user/lede/source/build_dir/host/u-boot-2014.10/include/libfdt_env.h:12,
from <command-line>:0:
/home/user/lede/source/staging_dir/host/include/byteswap.h:2:2: warning: #include_next is a GCC extension
#include_next <byteswap.h>
^~~~~~~~~~~~
HOSTCC tools/lib/fdtdec.o
HOSTCC tools/lib/fdtdec_common.o
HOSTCC tools/lib/libfdt/fdt.o
HOSTCC tools/lib/libfdt/fdt_ro.o
HOSTCC tools/lib/libfdt/fdt_rw.o
HOSTCC tools/lib/libfdt/fdt_strerror.o
HOSTCC tools/lib/libfdt/fdt_wip.o
HOSTCC tools/lib/md5.o
In file included from /home/user/lede/source/build_dir/host/u-boot-2014.10/include/compiler.h:46:0,
from /home/user/lede/source/build_dir/host/u-boot-2014.10/include/libfdt_env.h:12,
from <command-line>:0:
/home/user/lede/source/staging_dir/host/include/byteswap.h:2:2: warning: #include_next is a GCC extension
#include_next <byteswap.h>
^~~~~~~~~~~~
HOSTCC tools/lib/rsa/rsa-checksum.o
HOSTCC tools/lib/rsa/rsa-sign.o
In file included from tools/lib/rsa/rsa-sign.c:1:0:
/home/user/lede/source/build_dir/host/u-boot-2014.10/lib/rsa/rsa-sign.c: In function ‘rsa_remove’:
/home/user/lede/source/build_dir/host/u-boot-2014.10/lib/rsa/rsa-sign.c:156:2: warning: ‘ERR_remove_thread_state’ is deprecated [-Wdeprecated-declarations]
ERR_remove_thread_state(NULL);
^~~~~~~~~~~~~~~~~~~~~~~
In file included from /usr/include/openssl/x509_vfy.h:20:0,
from /usr/include/openssl/x509.h:309,
from /usr/include/openssl/pem.h:17,
from /home/user/lede/source/build_dir/host/u-boot-2014.10/lib/rsa/rsa-sign.c:13,
from tools/lib/rsa/rsa-sign.c:1:
/usr/include/openssl/err.h:246:1: note: declared here
DEPRECATEDIN_1_1_0(void ERR_remove_thread_state(void *))
^
In file included from tools/lib/rsa/rsa-sign.c:1:0:
/home/user/lede/source/build_dir/host/u-boot-2014.10/lib/rsa/rsa-sign.c: In function ‘rsa_sign_with_key’:
/home/user/lede/source/build_dir/host/u-boot-2014.10/lib/rsa/rsa-sign.c:213:2: warning: implicit declaration of function ‘EVP_MD_CTX_cleanup’ [-Wimplicit-function-declaration]
EVP_MD_CTX_cleanup(context);
^~~~~~~~~~~~~~~~~~
/home/user/lede/source/build_dir/host/u-boot-2014.10/lib/rsa/rsa-sign.c: In function ‘rsa_get_exponent’:
/home/user/lede/source/build_dir/host/u-boot-2014.10/lib/rsa/rsa-sign.c:279:21: error: dereferencing pointer to incomplete type ‘RSA {aka struct rsa_st}’ if (BN_num_bits(key→e) > 64)
^~
scripts/Makefile.host:134: recipe for target ‘tools/lib/rsa/rsa-sign.o’ failed
make[5]:
* [tools/lib/rsa/rsa-sign.o] Error 1
Makefile:1195: recipe for target ‘tools-only’ failed
make[4]: * [tools-only] Error 2
make[4]: Leaving directory ‘/home/user/lede/source/build_dir/host/u-boot-2014.10’ Makefile:46: recipe for target ‘/home/user/lede/source/build_dir/host/u-boot-2014.10/.built’ failed
make[3]:
* [/home/user/lede/source/build_dir/host/u-boot-2014.10/.built] Error 2
make[3]: Leaving directory ‘/home/user/lede/source/tools/mkimage’ tools/Makefile:148: recipe for target ‘tools/mkimage/compile’ failed
make[2]: * [tools/mkimage/compile] Error 2
make[2]: Leaving directory ‘/home/user/lede/source’ tools/Makefile:147: recipe for target ‘/home/user/lede/source/staging_dir/target-mips_24kc_musl-1.1.15/stamp/.tools_install_yynyynyyynyyyyynyynnyyynyyyyyyyyyyyyyyynnyynynnyyynnnyy’ failed
make[1]:
* [/home/user/lede/source/staging_dir/target-mips_24kc_musl-1.1.15/stamp/.tools_install_yynyynyyynyyyyynyynnyyynyyyyyyyyyyyyyyynnyynynnyyynnnyy] Error 2
make[1]: Leaving directory ‘/home/user/lede/source’ /home/user/lede/source/include/toplevel.mk:194: die Regel für Ziel „world“ scheiterte
make: *** [world] Fehler 2

Other cpu architectures have not been tested.

Closed by  Mathias Kresin
25.11.2016 10:47
Reason for closing:  Duplicate
Additional comments about closing:  

 FS#182 

Project Manager
Mathias Kresin commented on 22.11.2016 06:55

Please run the following commands on your Linux from the LEDE build directory and paste to output:

./scripts/diffconfig.sh
cat /etc/os_release
Project Manager
Mathias Kresin commented on 22.11.2016 06:57

For reference, looks like a duplicate of  FS#182 .

hngsvtdu@sharklasers.com commented on 22.11.2016 13:57

./scripts/diffconfig.sh
CONFIG_TARGET_lantiq=y
CONFIG_TARGET_lantiq_xrx200=y
CONFIG_TARGET_lantiq_xrx200_DEVICE_TDW8970=y
CONFIG_PACKAGE_libiwinfo=y
CONFIG_PACKAGE_libiwinfo-lua=y
CONFIG_PACKAGE_liblua=y
CONFIG_PACKAGE_libubus-lua=y
CONFIG_PACKAGE_libuci-lua=y
CONFIG_PACKAGE_lua=y
CONFIG_PACKAGE_luci=y
CONFIG_PACKAGE_luci-app-firewall=y
CONFIG_PACKAGE_luci-base=y
CONFIG_PACKAGE_luci-lib-ip=y
CONFIG_PACKAGE_luci-lib-jsonc=y
CONFIG_PACKAGE_luci-lib-nixio=y
CONFIG_PACKAGE_luci-mod-admin-full=y
CONFIG_PACKAGE_luci-proto-ipv6=y
CONFIG_PACKAGE_luci-proto-ppp=y
CONFIG_PACKAGE_luci-theme-bootstrap=y
CONFIG_PACKAGE_rpcd=y
CONFIG_PACKAGE_uhttpd=y
CONFIG_PACKAGE_uhttpd-mod-ubus=y
# CONFIG_TARGET_ar71xx_generic is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_A02RBW300N is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ALFAAP120C is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ALFAAP96 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ALFANX is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ALL0258N is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ALL0305 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ALL0315N is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_AP113 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_AP121MINI is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_AP121_16M is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_AP121_2M is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_AP121_4M is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_AP121_8M is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_AP132 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_AP135 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_AP136_010 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_AP136_020 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_AP143_16M is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_AP143_8M is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_AP147_010 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_AP152_16M is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_AP81 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_AP83 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_AP96 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_BXU2000N2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_CAP4200AG is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_DB120 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_DGL5500A1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_DHP1565A1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_DIR505A1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_DIR600A1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_DIR601A1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_DIR601B1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_DIR615C1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_DIR615E1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_DIR615E4 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_DIR615I1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_DIR615I3 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_DIR825B1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_DIR825C1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_DIR835A1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_DLRTDEV01 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_DR344 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_EAP300V2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_EAP7660D is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_EPG5000 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ESR1750 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ESR900 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_EWDORIN16M is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_EWDORINAP is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_EWDORINRT is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_F9K1115V2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_FR54RTR is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_HORNETUB is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_HORNETUBx2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_JA76PF is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_JA76PF2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_JWAP003 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_MR1750 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_MR600 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_MR900 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_MYNETREXT is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_MZKW04NU is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_MZKW300NH is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_N150R is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_NBG6616 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_NBG_460N_550N_550NH is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_OM2P is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_OM5P is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_OM5PAC is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_PB42 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_PB44 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_PB92 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_REALWNR1000V2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_REALWNR612V2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_TEW632BRP is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_TEW652BRP_FW is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_TEW652BRP_RECOVERY is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_TEW673GRU is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_TEW712BR is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_TEW732BR is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_TEW823DRU is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_TUBE2H16M is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_TUBE2H8M is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_WHRG301N is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_WHRHPG300N is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_WHRHPGN is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_WLAEAG300N is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_WLR8100 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_WNDAP360 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_WNR1000V2_VC is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_WNR2000V3 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_WNR2000V4 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_WNR2200 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_WP543_16M is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_WP543_2M is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_WP543_4M is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_WP543_8M is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_WPE72_16M is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_WPE72_4M is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_WPE72_8M is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_WPJ342_16M is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_WPJ344_16M is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_WPJ531_16M is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_WPJ558_16M is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_WPN824N is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_WRT160NL is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_WRT400N is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_WRTNODE2Q is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_WZR450HP2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_WZR600DHP is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_WZRHPAG300H is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_WZRHPG300NH is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_WZRHPG300NH2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_WZRHPG450H is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_YUN_16M is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_YUN_8M is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ZBTWE1526 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ZCN1523H28 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ZCN1523H516 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_antminer-s1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_antminer-s3 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_antrouter-r1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ap90q is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_archer-c5-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_archer-c7-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_archer-c7-v2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_archer-c7-v2-il is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_bhr-4grv2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_bsb is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_c-55 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_cap324 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_cap324-nocloud is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_carambola2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_cf-e316n-v2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_cf-e320n-v2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_cf-e380ac-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_cf-e380ac-v2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_cf-e520n is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_cf-e530n is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_cpe210-220 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_cpe510-520 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_cpe830 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_cpe870 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_cr3000 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_cr3000-nocloud is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_cr5000 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_cr5000-nocloud is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_dLAN_Hotspot is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_dLAN_pro_1200_ac is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_dLAN_pro_500_wp is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_dap-2695-a1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_dir-869-a1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_domywifi-dw33d is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_dr531 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_dragino2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_eap120 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_el-m150 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_el-mini is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_gl-ar150 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_gl-ar300 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_gl-ar300m is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_gl-domino is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_gl-inet-6408A-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_gl-inet-6416A-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_gl-mifi is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_hiwifi-hc6361 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_jwap230 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_mc-mac1200r is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_minibox-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_mr12 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_mr16 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_mw4530r-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_mynet-n600 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_mynet-n750 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_omy-g1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_omy-x1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_onion-omega is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_oolite is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_qihoo-c301 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_rnx-n360rt is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_rw2458n is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_smart-300 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_som9331 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tellstick-znet-lite is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-mr10u-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-mr11u-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-mr11u-v2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-mr12u-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-mr13u-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-mr3020-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-mr3040-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-mr3040-v2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-mr3220-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-mr3220-v2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-mr3420-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-mr3420-v2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wa701nd-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wa701nd-v2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wa7210n-v2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wa730re-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wa750re-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wa7510n is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wa801nd-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wa801nd-v2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wa801nd-v3 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wa830re-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wa830re-v2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wa850re-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wa860re-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wa901nd-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wa901nd-v2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wa901nd-v3 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wa901nd-v4 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wdr3320-v2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wdr3500-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wdr3600-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wdr4300-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wdr4300-v1-il is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wdr4310-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wdr4900-v2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wdr6500-v2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wdr7500-v3 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wpa8630 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wr1041n-v2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wr1043nd-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wr1043nd-v2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wr1043nd-v3 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wr2543-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wr703n-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wr710n-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wr710n-v2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wr710n-v2.1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wr720n-v3 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wr720n-v4 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wr740n-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wr740n-v3 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wr740n-v4 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wr740n-v5 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wr740n-v6 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wr741nd-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wr741nd-v2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wr741nd-v4 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wr741nd-v5 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wr743nd-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wr743nd-v2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wr802n-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wr810n is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wr841-v1.5 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wr841-v10 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wr841-v11 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wr841-v3 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wr841-v5 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wr841-v7 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wr841-v8 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wr841-v9 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wr842n-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wr842n-v2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wr842n-v3 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wr843nd-v1 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wr847n-v8 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wr941nd-v2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wr941nd-v3 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wr941nd-v4 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wr941nd-v5 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wr941nd-v6 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_tl-wr941nd-v6-cn is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ubdev01 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ubnt-air-gateway is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ubnt-air-gateway-pro is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ubnt-airrouter is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ubnt-bullet-m is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ubnt-loco-m-xw is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ubnt-ls-sr71 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ubnt-nano-m is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ubnt-nano-m-xw is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ubnt-rocket-m is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ubnt-rocket-m-ti is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ubnt-rocket-m-xw is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ubnt-rs is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ubnt-rspro is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ubnt-uap-pro is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ubnt-unifi is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ubnt-unifi-outdoor is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ubnt-unifi-outdoor-plus is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ubnt-unifiac-lite is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_ubnt-unifiac-pro is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_weio is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_wndr3700 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_wndr3700v2 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_wndr3800 is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_wndr3800ch is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_wndrmac is not set
# CONFIG_TARGET_ar71xx_generic_DEVICE_wndrmacv2 is not set
# CONFIG_TARGET_ar71xx_generic_Default is not set
# CONFIG_TARGET_ar71xx_mikrotik is not set
# CONFIG_TARGET_ar71xx_nand is not set

cat /etc/os_release → does not work. There is no such file.
OS is debian sid.
I tried building again. Same error. Bug is fully reproduicable.

Project Manager
Mathias Kresin commented on 24.11.2016 07:32

Does it work if you downgrade your OpenSSL headers?

apt install libssl1.0-dev
hngsvtdu@sharklasers.com commented on 25.11.2016 09:52

I made the downgrade from openssl/libssl 1.1.0c to 1.0.2j. Seems to be working fine. Its compiling now for long time where before the error appear after just few seconds.

I think this bug should still have high priority. Many OS would be updated next days to 1.1.0 . For example on arch linux recent 1.0.2j Version is been tagged as outdated in their packages and would probably be updated quickly.

Openssl 1.1.0 is already a stable release.

https://www.openssl.org/source/

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing