OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Packages
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version openwrt-18.06
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Tomas Klouda - 24.03.2020
Last edited by Baptiste Jonglez - 28.09.2020

FS#2926 - busybox: less: search doesn't work

Steps to reproduce:
Open any text file in less and press “/” or “?” key to start search.

It does nothing on OpenWRT, which is very unfortunate...

 


Closed by  Baptiste Jonglez
28.09.2020 20:47
Reason for closing:  Not a bug
Additional comments about closing:  

This is just the default config

Project Manager
Baptiste Jonglez commented on 28.09.2020 20:46

This is expected, many busybox options are disabled to lower flash size requirements. See also https://dev.archive.openwrt.org/ticket/7132

You can enable this in your own build (look for BUSYBOX_CUSTOM and FEATURE_LESS_REGEXP in menuconfig), or else just install the full-featured "less" package.

If you really want to see this in future versions of openwrt (which will already need higher flash size anyway), send a patch with a size comparison: https://openwrt.org/submitting-patches

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing