OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version openwrt-19.07
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by AC - 22.03.2020

FS#2919 - 18.06 to 19.07 upgrade fails [Netgear WNDR4300 v1]

> If your device is not supported by the image You may encounter the error “Device not supported by this image” or “Image check failed”. In that case, please report the issue so that it can be fixed for the next 19.07.X minor release.

https://openwrt.org/docs/guide-user/installation/ar71xx.to.ath79


Tried to upgrade from

openwrt-18.06 branch (git-19.020.41695-6f6641d) / OpenWrt 18.06.2 r7676-cddd7b4c77

[to]

http://downloads.openwrt.org/releases/19.07.2/targets/ar71xx/nand/openwrt-19.07.2-ar71xx-nand-wndr4300-squashfs-sysupgrade.tar

I alternately receive the error “The connection was reset” or “Device not supported by this image”


> for LuCI: check “Force upgrade”

This option was not available

> for command-line sysupgrade: use sysupgrade -F -n <your-device-19.07-image-sysupgrade.bin>

This option succeeded and the new build is working normally, thanks

note: Once this issue is resolved, would it be feasible to host upgrade images on a free service like GitHub, so checks for new version could be performed through the web interface (similar to GL.Inet routers)

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing