OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Kernel
  • Assigned To No-one
  • Operating System All
  • Severity High
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by xrouterservice - 22.03.2020
Last edited by Petr Štetiar - 29.03.2020

FS#2914 - Cannot compile the kernel program under the latest source code

touch /home/sda3/openwrt/build_dir/target-x86_64_musl/linux-x86_64/oaf-3.0/.configured_68b329da9893e34099c7d8ad5cb9c940
rm -f /home/sda3/openwrt/build_dir/target-x86_64_musl/linux-x86_64/oaf-3.0/.built
touch /home/sda3/openwrt/build_dir/target-x86_64_musl/linux-x86_64/oaf-3.0/.built_check
cat /dev/null > /home/sda3/openwrt/staging_dir/target-x86_64_musl/pkginfo/oaf.symvers; for subdir in .; do cat /home/sda3/openwrt/staging_dir/target-x86_64_musl/pkginfo/*.symvers 2>/dev/null > /home/sda3/openwrt/build_dir/target-x86_64_musl/linux-x86_64/oaf-3.0/$subdir/Module.symvers; done
make -C "/home/sda3/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-5.4.24" ARCH="x86" CROSS_COMPILE="x86_64-openwrt-linux-musl-" SUBDIRS="/home/sda3/openwrt/build_dir/target-x86_64_musl/linux-x86_64/oaf-3.0" EXTRA_CFLAGS=""  modules
make[3]: Entering directory '/home/sda3/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-5.4.24'
  CALL    scripts/checksyscalls.sh
  CALL    scripts/atomic/check-atomics.sh
  DESCEND  objtool
  LINK     /home/sda3/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-5.4.24/tools/objtool/objtool
/usr/bin/ld: warning: libc.so, needed by /home/sda3/openwrt/staging_dir/target-x86_64_musl/usr/lib/libelf.so, not found (try using -rpath or -rpath-link)
/usr/bin/ld: /home/sda3/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-5.4.24/tools/objtool/objtool: hidden symbol `fstat' in /usr/lib/x86_64-linux-gnu/libc_nonshared.a(fstat.oS) is referenced by DSO
/usr/bin/ld: final link failed: Bad value
collect2: error: ld returned 1 exit status
Makefile:49: recipe for target '/home/sda3/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-5.4.24/tools/objtool/objtool' failed
make[5]: *** [/home/sda3/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-5.4.24/tools/objtool/objtool] Error 1
Makefile:67: recipe for target 'objtool' failed
make[4]: *** [objtool] Error 2
Makefile:1794: recipe for target 'tools/objtool' failed
make[3]: *** [tools/objtool] Error 2
make[3]: Leaving directory '/home/sda3/openwrt/build_dir/target-x86_64_musl/linux-x86_64/linux-5.4.24'
Makefile:46: recipe for target '/home/sda3/openwrt/build_dir/target-x86_64_musl/linux-x86_64/oaf-3.0/.built' failed
make[2]: *** [/home/sda3/openwrt/build_dir/target-x86_64_musl/linux-x86_64/oaf-3.0/.built] Error 2
make[2]: Leaving directory '/home/sda3/openwrt/feeds/OpenAppFilter/oaf'
time: package/feeds/OpenAppFilter/oaf/compile#7.06#5.48#12.20
package/Makefile:111: recipe for target 'package/feeds/OpenAppFilter/oaf/compile' failed
make[1]: *** [package/feeds/OpenAppFilter/oaf/compile] Error 2
make[1]: Leaving directory '/home/sda3/openwrt'
/home/sda3/openwrt/include/toplevel.mk:225: recipe for target 'package/feeds/OpenAppFilter/oaf/compile' failed
make: *** [package/feeds/OpenAppFilter/oaf/compile] Error 2


Closed by  Petr ┼átetiar
29.03.2020 18:28
Reason for closing:  Not a bug
Additional comments about closing:  

Requested.

llccd commented on 24.03.2020 10:30

Seems there is somgthing wrong in third-party OpenAppFilter package
Try edit package/feeds/OpenAppFilter/oaf/Makefile
Change

SUBDIRS="$(PKG_BUILD_DIR)"

to

M="$(PKG_BUILD_DIR)"

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing