OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version openwrt-19.07
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Ilya Smirnov - 15.03.2020
Last edited by Petr Štetiar - 25.04.2020

FS#2903 - /dispatcher.lua:315 after enable DNS lookup in realtime/connections

hello.

asus ac-56u
OpenWrt 19.07.2 r10947

Trying to enable “DNS lookup” in /status/realtime/connections
and get this until device reboot

/usr/lib/lua/luci/dispatcher.lua:315: /etc/config/luci seems to be corrupt, unable to find section ‘main’ stack traceback:

[C]: in function 'assert'
/usr/lib/lua/luci/dispatcher.lua:315: in function 'dispatch'
/usr/lib/lua/luci/dispatcher.lua:208: in function </usr/lib/lua/luci/dispatcher.lua:207>
 


Closed by  Petr Štetiar
25.04.2020 12:08
Reason for closing:  Different project
Additional comments about closing:  

Problems to be reported here are for the OpenWrt/LEDE Project targets, sources, toolchain, core packages, build procedures, distribution and infrastructure. Guidelines for submitting a good bug report can be found at the OpenWrt/LEDE Project website. Problems related to LuCI or OpenWrt packages need to be reported in their repositories:

  LuCI -
https://github.com/openwrt/luci/issues
  Packages -
https://github.com/openwrt/packages/issu
es
Paul Oranje commented on 15.03.2020 08:56

Cannot reproduce this
at http://router/cgi-bin/luci/admin/status/realtime/connections on netgear,r7800 19.07.2, r10947-65030d81f3

Ilya Smirnov commented on 17.03.2020 14:59

I tried to play again.
I remembered that I launched qbittorrent then.
I don’t know if this is a mistake, given the high number of connections ...
But it reproduces like this:
Qbittorrent settings.
total number of connections - 1000
torrent - 100
recoil slots - 1000
Immediately after starting qbittorrent, many tcp connections open. In my connectoin section there were 700 tcp and 1800 udp of current connections.
At this point, if you enable "dns lookup", an error appears.
Then gradually the number of tcp connections decreases and the error no longer appears.
https://ibb.co/FmJPvbq https://ibb.co/gJz7Rz3 https://ibb.co/fqmPjcn

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing