OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Kernel
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by kodewdle - 12.03.2020

FS#2900 - ath79 nand trunk bootloop

1) WNDR3700v4 (likely wndr4300v1 too)
2) trunk build, compiles fine for 4.19 and 5.4
3) build, try to boot, will bootloop on 4.19 or 5.4 testing kernel

commit: ath79: add support for kernel 5.4 this commit edits: target/linux/ath79/nand/config-default diff this is causing the bootloop to happen. however, if:

CONFIG_MTD_NAND=y
CONFIG_MTD_NAND_AR934X=y
CONFIG_MTD_NAND_ECC=y

is readded, the bootloop won’t happen and the build will load.
i don’t know if all three of these are needed or just CONFIG_MTD_NAND i also tested with this on 5.4 but i still have the bootloop however, that’s probably expected i know it’s currently a work in progress.
so, this change will only fix 4.19

after i patched this locally: OpenWrt SNAPSHOT r12586+5-3b45a3b388 also i should note, as of this version exFAT (specifically, kmod-fs-exfat0) won’t compile at 4.19 but that’s another issue that i’m sure will be resolved in no time.

kodewdle commented on 12.03.2020 12:52

reference to github mirror: here

kodewdle commented on 12.03.2020 13:41

Will do, should I also attempt 5.4? I started a 4.19 build right now. Will report back shortly.

Project Manager
David Bauer commented on 12.03.2020 14:22

Kernel 5.4 still has major bugs for ath79, but if you would like to do it, go ahead!

kodewdle commented on 12.03.2020 14:28

Okay, the build just loaded and works with that commit as well (on 4.19). OpenWrt SNAPSHOT r12618

edit: building a 5.4, why not? :)

kodewdle commented on 12.03.2020 15:08

Okay, kernel 5.4 test didn't build now (expected still, of course) this is the error i collected during the attempt. I don't expect this to be fixed soon or anything, the issue from this ticket is resolved. Thanks for your time. :)

realmicu commented on 27.03.2020 23:17

Please use latest master, David Bauer recently provided a patch that adapts ar934x-nand driver to 5.4. Also please use GCC 9.3.0, default version 8.4.0 may produce unbootable kernel ("Kernel panic - not syncing: Unexpected DSP exception") for certain ath79 devices (confirmed for routers based on Atheros 9344). See FS#2928.

kodewdle commented on 29.03.2020 05:21

i tested 5.4 with gcc 9.3.0 however the device still wouldn't boot, i tried the sysupgrade first then tftp the img file however both didn't work so i remade it with 4.19 and that one took (still using gcc9):

Linux version 4.19.108 (kodewdle@github) (gcc version 9.3.0 (OpenWrt GCC 9.3.0 r12846-258f070d1a)) #0 Sat Mar 28 16:14:15 2020

so, unless i did something wrong using a higher gcc didn't help for my device :( thanks for mentioning it however, willing to test more just let me know :)

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing