OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Kernel
  • Assigned To No-one
  • Operating System All
  • Severity High
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Shang Jia - 14.11.2016
Last edited by Jo-Philipp Wich - 01.06.2017

FS#285 - Kernel panic on ebox-3300 (Vortex86DX CPU)

The firmware (Reboot, HEAD r2115) failed to boot on the x86 hardware of ebox3300a (http://www.compactpc.com.tw/product.aspx?act=detail&id=16). The CPU does not support PAE so I used legacy profile to compile. The boot log says that the CPU supports x2apic (really? Also no such option in BIOS) but the kernel does not:

[ 0.000000] Checking if this processor honours the WP bit even in supervisor mode... Ok.
[ 0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[ 0.000000] NR_IRQS:2304 nr_irqs:32 16
[ 0.000000] Console: colour VGA+ 80×25 [ 0.000000] console [tty0] enabled
[ 0.000000] console [ttyS0] enabled
[ 0.000000] tsc: Fast TSC calibration using PIT
[ 0.000000] tsc: Detected 933.313 MHz processor
[ 0.010013] Calibrating delay loop (skipped), value calculated using timer frequency.. 1866.62 BogoMIPS (lpj=9333130)
[ 0.010543] pid_max: default: 32768 minimum: 301
[ 0.011016] Mound-cache hash table entries: 1024 (order: 0, 4096 bytes)
[ 0.011336] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
[ 0.013527] Last level iTLB entries: 4KB 0, 2MB 0, 4MB 0
[ 0.013805] Last level dTLB entries: 4KB 0, 2MB 0, 4MB 0, 1GB 0
[ 0.014084] CPU: Vortex86 SoC 05/02 (family: 0×5, model: 0×2, stepping: 0×2)
[ 0.020554] Performance Events: no PMU driver, software events only.
[ 0.020923] Kernel panic - not syncing: BIOS has enabled x2apic but kernel doesn’t support s2apic, please disable x2apic in BIOS.
[ 0.020923]
[ 0.021544] Rebooting in 1 seconds..

In contrast, the machine boots well with openwrt Chaos Calmer 15.05.1 x86 generic (without IDE controller driver, though), and it also works well with the kernel from Debian sid installation iso.

Besides, there are patches that fixes its IDE controller detection as well as ethernet adapter (https://lists.openwrt.org/pipermail/openwrt-devel/2014-October/028981.html and https://lists.openwrt.org/pipermail/openwrt-devel/2014-October/028983.html). Since there is not supposed to be too many specific profiles, should we adopt these patches?

Closed by  Jo-Philipp Wich
01.06.2017 23:53
Reason for closing:  Fixed
Additional comments about closing:  

X2APIC forcibly disabled with ht tps://git.lede-project.org/1893b5622df4c 7b8be0f2bc5bb73756ac1ded1eb

Project Manager
Hauke Mehrtens commented on 25.12.2016 17:32

This problem is probably caused by this change in upstream Linux kernel:
https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=d524165cb8dbb2ce5916cd7682236b9324ae2644

it is not possible to activate x2apic support in a 32 bit kernel.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing