OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Base system
  • Assigned To
    Rafał Miłecki
  • Operating System All
  • Severity High
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by pmgp - 16.02.2020
Last edited by Yousong Zhou - 26.03.2020

FS#2837 - MT7620: JFFS2 errors with trunk, Archer C20v1 and C20i

I have at least five mt7620 devices (TPLINK Archer C20v1, C20i) that started having flash write errors at startup with trunk.

Had already a similar problem with ar79, can it be related?
https://bugs.openwrt.org/index.php?do=details&task_id=2742&order=id&sort=desc&pagenum=2

OpenWrt SNAPSHOT, r12235-49caf9f98a
Linux OpenWrt 4.14.169 #0 Sat Feb 15 07:57:49 2020 mips GNU/Linux

[    0.639218] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.

[    9.296544] jffs2: notice: (414) jffs2_build_xattr_subsystem: complete building xattr subsystem, 4 of xdatum (3 unchecked, 1 orphan) and 16 of xref (1 dead, 0 orphan) found.
[   37.831875] jffs2: Erase at 0x00378000 failed immediately: errno -22

[    9.301481] jffs2: notice: (414) jffs2_build_xattr_subsystem: complete building xattr subsystem, 5 of xdatum (3 unchecked, 2 orphan) and 15 of xref (2 dead, 0 orphan) found.
[   72.033254] jffs2: Erase at 0x00378000 failed immediately: errno -22

[    9.300037] jffs2: notice: (414) jffs2_build_xattr_subsystem: complete building xattr subsystem, 5 of xdatum (3 unchecked, 2 orphan) and 16 of xref (2 dead, 0 orphan) found.
[   30.629708] jffs2: Erase at 0x00378000 failed immediately: errno -22

[    9.294011] jffs2: notice: (414) jffs2_build_xattr_subsystem: complete building xattr subsystem, 5 of xdatum (3 unchecked, 2 orphan) and 15 of xref (2 dead, 0 orphan) found.
[   31.409183] jffs2: Erase at 0x00378000 failed immediately: errno -22

[    9.286101] jffs2: notice: (411) jffs2_build_xattr_subsystem: complete building xattr subsystem, 4 of xdatum (3 unchecked, 1 orphan) and 17 of xref (1 dead, 0 orphan) found.
[   93.305969] jffs2: Erase at 0x00378000 failed immediately: errno -22
Closed by  Yousong Zhou
26.03.2020 09:48
Reason for closing:  Fixed
Additional comments about closing:  

http://g it.openwrt.org/fdfca33350150644481096f1c 7a80db2b670cdec

Kazuhiro Ito commented on 27.02.2020 08:29

My three ramips devices have the same problem. As far as I confirmed, it occurs since commit 15a0701cdde8eeae2a54880b813cdb8cdc09a384.

Kazuhiro Ito commented on 01.03.2020 11:04

Reverting the above commit resolved the problem in my devices.

pmgp commented on 01.03.2020 17:28

I confirm, no errors after reverting it!

Admin
Petr Štetiar commented on 02.03.2020 13:03

Workaround(revert) for this issue has been proposed https://patchwork.ozlabs.org/patch/1247614/

dormancygrace commented on 02.03.2020 14:06

Confirm. Just found commit 15a0701cdde8eeae2a54880b813cdb8cdc09a384 by myself. I`m using Xiaomi Router 4A Gigabit, MT7621

Project Manager
Rafał Miłecki commented on 03.03.2020 07:44

Someone please provide a complete dmesg from:

  • master
  • master with 15a0701cdde8 reverted

so we can actually understand the issue.


 FS#2742  was reported before above commit and its dmesg-s don't contain

  Creating 1 MTD partitions on "rootfs":

so it a different issue.

dormancygrace commented on 03.03.2020 11:17

How can i revert? or i can go back to previous commit and build.

Project Manager
Rafał Miłecki commented on 03.03.2020 11:22

Use git command

  git revert 15a0701cdde8
dormancygrace commented on 03.03.2020 11:57

It was not that easy, but seems worked, after some more commands. It`s compiling now.

dormancygrace commented on 03.03.2020 13:38

done

pmgp commented on 03.03.2020 21:15

Here are mine, notice trunk at over 8 sec uptime.

Kazuhiro Ito commented on 04.03.2020 04:21

Here are mine. A device is Tama W06. *-sysupgrade.log are dmesg just after sysupgrade. *-reboot.log are dmesg on simple reboot.

Project Manager
Rafał Miłecki commented on 06.03.2020 16:26

I've one more (hopefully the last) debugging request. Can you please:

  1. Switch back to the master branch (don't revert my 15a0701cdde8 commit anymore)
  2. Execute: rm target/linux/generic/pending-*/41[12]*
  3. Compile image, flash it, provide boot log, test it
dormancygrace commented on 06.03.2020 22:07

How to unrevert (back to master)?

Project Manager
Rafał Miłecki commented on 06.03.2020 22:48

You can remove the last local commit (like revert commit) and local changes doing:
git reset –hard HEAD~1
after that you can keep doing "git pull"s.

Or you can point what to switch to manually doing:
git fetch
git reset –hard origin/master

dormancygrace commented on 06.03.2020 23:46

downloaded new copy. it doesn`t start at all. i`ll check what`s going on in the morning

Kazuhiro Ito commented on 07.03.2020 07:29

Here is. The device is Planex VR500. Bootlogs on master with and without reverted commit 15a0701cdde8 also uploaded. The kernel without target/linux/generic/pending-*/41[12]* may make the device inaccessible via network.

dormancygrace commented on 07.03.2020 08:52

So, serial is the only way? Cause I think router works, but without network

dormancygrace commented on 07.03.2020 10:49

serial log

Kazuhiro Ito commented on 07.03.2020 11:45

Ethernet network switch was not configured on my device, so serial was the only accessible way.

Project Manager
Baptiste Jonglez commented on 07.03.2020 23:27

FYI, the offending commit got reverted in fdfca33350150644481096f1c7a80db2b670cdec.

pmgp commented on 18.03.2020 14:34

I confirm that trunk is good. Close requested.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing