OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity High
  • Priority Very Low
  • Reported Version All
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by PlumWolf - 11.02.2020

FS#2831 - 2.4Ghz Wifi speed degradation on WNDR3800

I found that on WNDR3800, ath79 build 2.4Ghz Wifi slower than ar71xx build.
ath79 build only get about 3.5MB/s (2.4Ghz 40Mhz), ar71xx build get about 10MB/s. (2.4Ghz 40Mhz)
Same network, Same wifi channel, test on speedtest.
I think this is a serious performance issue.

- Device problem occurs on
WNDR3800(ath79) latest sources at master branch.

- Steps to reproduce
install ar71xx build
test on speedtest.net (Samsung S6 and Sony xz1 use 2.4G wifi)
install ath79 build
test on speedtest.net (Samsung S6 and Sony xz1 use 2.4G wifi)
download speed only half of ar71xx build.


Scot commented on 25.04.2020 12:40

Hello.

Just found that out today as I was upgrading my WNDR3800 from 18.06.8 to 19.07.2.

I have a 50mbit connection. When running 18.06.8 I get around 48mbit. When running 19.07.2 I get around 8-12mbit. This happens with a distance to the router of around 1 meter. No obstacles between.

Indeed this is a bad regression. I also deleted all config files and tried to use a fresh install of 19.07.2. Didn't make any difference.

Please devs, take a look into it.

Thank you for your great work!

arminfuerst commented on 25.04.2020 15:17

I have the same device, but cannot confirm a performance difference after upgrading to 19.07.x (ath79). But the WiFi never was as fast as my internet connection, devices being as close as 1 meter never got more than around 25MBit.
I made a "clean upgrade", meaning I upgraded without keeping the config and reentered the complete config. I upgraded from 18.06.7 to 19.07.2.
Perhaps I can also assist with this but and probably we can find out why my WiFi performance always was poor on this device...

Scot commented on 25.04.2020 20:20

I see. So I tried again after reading your comment.

First I flashed 19.07.2 (ath79) to the router (not 1CHNAS but v1 by the way). Did a reset to remove all config files. Connected via Lan cable: 50 MBit. Connected via 2.4G Wifi: around 8-12MBit again. No difference with channel, encryption, 20 or 40Mhz.

Flashed 18.06.8 again. Resetted to removed all config files. Connected via LAN cable: 50MBit. Connected via 2.4G Wifi: around 46-48MBit.

Distance to the router always around 1 meter. No walls or furniture in between.

I wonder why your results differ from mine. You have the v1 model? Did you try 18.06.8? Also reset the config? Whats the Lan speed, what's the Wifi speed for 18.06.8?

arminfuerst commented on 26.04.2020 09:44

To be honest, I'm not sure which version I have. On the "Overview" of OpenWRT, the architecture says "Atheros AR7161 rev 2". I also attach a photo, perhaps this shows the version?
I did not try 18.06.8 and testing it would be quite a big effort, since this is my main router and making changes means a complete loss of my connection to the internet.
I am very sure the behavior would be identical, since every version I had installed showed the same behavior. I'm not sure whether I started with 10.03.1 or 12.09 and I was missing nearly no update (perhaps I detected 3 updates too late, meaning the next but one was already available). I also switched to LEDE (and obviously "back").
With following this bug I hoped to find out why the performance is quite poor. I tried multiple distances, starting from 1 meter, no walls or furniture as far as 20 meters with two main walls in between. The performance didn't drop dramatically (10-15MBit).
I tried a lot of different configurations (Operation frequency "N"/"Legacy", Channel "auto"/looked for an unused channel in my area, Width "20MHz"/"40MHz", played around with max. transmit power), but I never got dramatically different results.
Do you have a 5GHz WLAN configured/in use?

Scot commented on 13.05.2020 11:20

I found some time now to do another test. Unfortunately still the same. This means OpenWRT version 18.06.8 works as fast as my provider is delivering. I get 48-50 MBit even through a wall and 5 meters away from the router. I have the same version, Atheros AR7161 rev 2. As for the radio, i use Atheros AR9223 802.11bgn. As parameters I have set encryption to WPA2 PSK (CCMP), Operating frequenzy is set to N, Channel Auto, Width 40, I do not allow legacy 802.11b rates and I have set Force 40MHz mode. No other modifications. If that doesnt work for you, I am out of ideas. Good luck.

arminfuerst commented on 13.05.2020 19:00

@Scot: Beside of "Do not allow legacy 802.11b rates", "Force 40MHz mode" and "WPA2 PSK (CCMP)", your settings are identical to mine. I tried setting these values - every on it's own and every combination - and the speed is always comparable.
I also played around with other parameters (power, set the channel to 1 and to 13, I changed the Country Code between "driver default", "AT" and "00"), I always get around 20MBit while I get 40MBit stable though a LAN port. I also checked the load during a speedtest, there was no eye-catching change (always around 1).
I am out of ideas - I really hoped we could solve this mystery together.

PlumWolf commented on 14.05.2020 17:06

Try AR71xx version.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing