OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Nathan Samson - 10.02.2020

FS#2830 - MikroTik RB951G-2HnD does not boot

Supply the following if possible:
- MikroTik RB951G-2HnD
- Tried 19.07.1 and 18.06.7

Steps to reproduce
- Network boot from port 1
- Have another device connected to network port 2
- See it sometimes (so far it happened 2 times out of approx 10 tries) ask for a network address after finishing loading the initramfs image
- When it has assigned an IP, it also gives away IP’s to connected clients
- Running ping from a client gives approx 95% packet loss

Note on https://openwrt.org/toh/mikrotik/rb951g_2hnd it mentions the gigabit switch doesn’t work properly without a patch
Note I tried compiling a patch for 19.07.1 (same result), or even loading in the kernel module built into the initram fs image (self built) (https://github.com/fluciotto/openwrt-kmod-rb951g-2hnd-eth-fix)
but neither options seem to have any improvement.

Note the wiki page mentions only rev 3 needs this patch

  The new version (rev 3, requires patch) can apparently be distinguished from the old version (rev 2, works out-of-the-box) by the MAC address:
     The old one starts with D4:CA:6D
     The new one starts with 4C:5E:0C

My Mac Address starts with 74:4D:28. So either this is a newer revision (which might need a different patch?) or they ran out of mac address space, and the same HW revision has added another range...

 


Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing