OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version openwrt-19.07
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Damien - 07.02.2020

FS#2818 - Current time displayed incorrectly in v.19.07 system tab

- Device problem occurs on
Aerohive HiveAP-121

- Software versions of OpenWrt/LEDE release, packages, etc.
OpenWrt 19.07.1 r10911-c155900f66 / LuCI openwrt-19.07 branch git-20.029.45734-adbbd5c

- Steps to reproduce
This is evident when you have two AP (exact same hardware) side by side running v.19.07.1 and v.18.06.5

The issue:
After upgrading firmware from 18.06.5 to 19.07.1 we noticed that the current time reported incorrectly on the ‘System’ tab in GUI.

Please note, current time IS reported correctly in the ‘Status’ tab on both versions.

Please note, GUI is accessed using a desktop version of Debian GNU/Linux 10 (buster), with Firefox ESR 68.4.1esr (64-bit).

Please note, Firefox configuration has been modified - hardened to prevent remote sites code loaded to the browser to detect local time zone.

Using the same browser with the exact same configuration shows current time been displayed correctly in firmware v.18.06.5 and displayed incorrectly only on the system tab in firmware version 19.07.1.

Please see screenshots attached.

Development team - thank you for your efforts in writing this code and making it available free of charge. You guys are awesome! :)

Damien.


Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing