OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version Trunk
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Bill - 06.02.2020

FS#2816 - Poor upload speed with Relayd and Mediatek SoCs

Raising a bug report to highlight there may be a problem with relayd performance issues with MT7621 and MT7628 SoCs

Wireless signal strength and link speeds reported by the devices are OK when displayed in LuCI, but the measured data throughput on upload link is extremely poor. Less than 1 Mbps.

Examples of affected devices include Xiaomi R3G, RT-AC57U and C50 v4.

Xiaomi R3G & RT-AC57U

Archer C50 v4

When using prebuilt owrt images, there is nothing in system log to indicate there are any problems.

DarkerTimes commented on 29.03.2020 13:31

I tested it again with latest snapshot for xiaomi-mir3g MT7621 29.03.2020.
It is still the same for me. 2.4GHz works fine, if i just change to 5GHz with the same settings the upload is broken (~1MBit).
I tried all the WiFi settings available, but still no luck getting it to work.

(Xiaomi 3G Post)

DarkerTimes commented on 19.04.2020 11:50

Update from my side: Today I flashed a new snapshot (19.04.2020) and the ethernet ports broke probably because i kept saving settings. So I flashed again over wifi and started testing from scratch again.
In the 5GHz client wifi setting i typed a random number (3000) in the setting "Fragmentation threshold". And now it seems to work perfectly.
Can someone test that too?

Bill commented on 19.04.2020 18:40

I just tried this on RT-AC57U with 19.07.2. Any attempt to edit the fragmentation threshold in LuCI seems to break routing. I could ping my ISP facing router LAN IP on other side of the bridge, but could not ping any external internet IP address.

I then installed latest r13021 snapshot and discovered the interface names have changed. eg. WAN interface should be eth0.2. It is currently called 'wan'. The switch menu is missing from LuCI and the /etc/config/network file is missing factory default switch/VLAN configuration.

I decided not to carry out any further tests until the issue with switch configuration is restored to normal with future snapshots.

caiom commented on 29.06.2020 23:11

I can confirm this bug with C50 v4 (BR). The upload speed on the 5Ghz radio is, at most, 1mbps.

However setting the Fragmentation Threshold to 3000 solved the issue aswell!
Now it is 70mbps :)

Thomas Beckler commented on 13.01.2021 16:09

I can confirm this bug on a Netgear R6220 (MT7621). Same observations like above.

  • Only present using relayd (standard access point operation in 2.4 GHz and 5 GHz WIFI shows high throughput) with any WIFI client
  • Only present using 5 GHz WIFI (using relayd on 2.4 GHz WIFI is OK)
  • low throughput ~1 Mbit/s
  • issue can be "compensated" by changeing the "fragmentation threshold".

Thank you for this bug report, as

  • I always thought it is related to my specific router and the hardware ( FS#3080  - ramips/mt7621 Netgear R6220 WIFI 5 GHz issue).
  • I never thought this could be related to relayd

Can somebody explain, why this issue is related to "relayd"? I though "relayd" is not affecting the "WIFI low level performance", as it is operating one or two layers higher

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing