OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version openwrt-19.07
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Luiz Angelo Daros de Luca - 19.01.2020
Last edited by Adrian Schmutzler - 28.01.2020

FS#2751 - Device tl-wr2543n not supported while upgrading from ar71xx to ath79

Upgrade from ar71xx (18.06.6) to ath79 (19.07.0) failed on my TP-Link TL-WR2543ND-V1:

root@router:/tmp# sysupgrade openwrt-19.07.0-ath79-generic-tplink_tl-wr2543
-v1-squashfs-sysupgrade.bin 
Device tl-wr2543n not supported by this image
Supported devices: tplink,tl-wr2543-v1 tl-wr2543-v1
Image check 'fwtool_check_image' failed.

tl-wr2543-v1 is missing the last “n”. It was used in BOARD_NAME (https://github.com/openwrt/openwrt/blob/openwrt-18.06/target/linux/ar71xx/image/generic-tp-link.mk#L418) but not in the profile name.

Is it safe to do a force upgrade?

It flashed without warning to target ar71xx (https://downloads.openwrt.org/releases/19.07.0/targets/ar71xx/generic/openwrt-19.07.0-ar71xx-generic-tl-wr2543-v1-squashfs-sysupgrade.bin)

It also failed to flash between the same version 19.07.0 but from ar71xx to ath79:

root@router:~# sysupgrade -T /tmp/openwrt-19.07.0-ath79-generic-tplink_tl-w
r2543-v1-squashfs-sysupgrade.bin 
Device tl-wr2543n not supported by this image
Supported devices: tplink,tl-wr2543-v1 tl-wr2543-v1
Image check failed.
Closed by  Adrian Schmutzler
28.01.2020 12:27
Reason for closing:  Fixed
Additional comments about closing:  

Fixed in master and 19.07.

Luiz Angelo Daros de Luca commented on 19.01.2020 20:32

I'm aware (actually, I was trying to reproduce it with 19.07).
Independently of that issue, the device name mismatch should be fixed.

Luiz Angelo Daros de Luca commented on 27.01.2020 21:53

This bug is already fixed in trunk. It looks like this is the fix: https://github.com/openwrt/openwrt/commit/07ce940b77e6aceb095b0a16dda41e190dfc5b87

Please, backport to 19.07 before 19.07.1.

https://bugs.openwrt.org/index.php?do=details&task_id=2742&order=id&sort=desc does not affect 19.07.0

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing