OpenWrt/LEDE Project

  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Medium
  • Priority Very Low
  • Reported Version openwrt-19.07
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Jernej Simončič - 18.01.2020

FS#2750 - Wireless on Netgear WNDR3700v2 not working

After upgrading my Netgear WNDR3700 v2 to 19.07 (ath79 target), the WiFi cards aren’t detected.

Here are the outputs of dmesg, logread, lsmod | grep ath, ls /sys/bus/pci/*, lspci -vnn; at the recommendation of PaulFertser in #openwrt, I tried echo -n 168c ff1d > /sys/bus/pci/drivers/ath9k/new_id, which resulted in some error messages in dmesg, but the WiFi interfaces still aren’t detected (wifi config produces an empty file).

With ar71xx target, wifi works; the cards seem to have a different http://p.0au.de/3393221e/, too. dmesg, logread, ls /sys/bus/pci/*.

Jernej Simončič commented on 18.01.2020 23:06

More info: looks like ath79 failed because kmod-owl-loader wasn't included in my build (when I was building the firmware, I took my Archer C7 config and just changed the Target Profile to Netgear WNDR3700v2); with owl-loader the WiFi works fine.

Project Manager
Adrian Schmutzler commented on 08.07.2020 18:20

So, can you please check whether the problem exists with our snapshot builds? There, kmod-owl-loader should be selected.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing