OpenWrt/LEDE Project

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category Base system
  • Assigned To No-one
  • Operating System All
  • Severity Critical
  • Priority Very Low
  • Reported Version openwrt-19.07
  • Due in Version Undecided
  • Due Date Undecided
  • Private
Attached to Project: OpenWrt/LEDE Project
Opened by Pepe - 09.01.2020
Last edited by Baptiste Jonglez - 13.01.2020

FS#2721 - HG556a fails to boot on 19.07

Supply the following if possible:
- Device problem occurs on
HG556a A, B and C versions
- Software versions of OpenWrt/LEDE release, packages, etc.
OpenWrt 19.07 rc1, rc2 and final, generic and smp
- Steps to reproduce

 

Flash HG556a any version (A, B or C) with openwrt 19.07 version.
Router reboots, and inmediately hangs. Power led is still. No boot.

Tried with compilation dated: Tue Jan 7 06:39:38

Closed by  Baptiste Jonglez
13.01.2020 23:47
Reason for closing:  Duplicate
Additional comments about closing:  

 FS#2202  and  FS#1951 

Project Manager
Baptiste Jonglez commented on 13.01.2020 15:57

How did you install 19.07? Sysupgrade from an existing OpenWrt? Which version?

Please use a serial connection to understand what happens during boot.

Pepe commented on 13.01.2020 16:55

Thank you for your answer.
I installed it 3 ways:
from own recovery router system.
from sysupgrade command
and from luci.

Both last, from Openwrt 18.06.6
Tested in two routers. And also in spanish openwrt forum, other users reported the same problem.

I don't have serial connection. I have opened the case and seen that the serial pins arent there. There are no pins soldered. I am bad on soldering, so I prefer not doing that.
I think I can try use serial without soldering. Only by making contact. I'll try.

Pepe commented on 13.01.2020 18:25

I did it. Here is the info displayed by terminal:

CFE version cfe.d081.5003 for BCM96358 (32bit,SP,BE)
Build Date: Wed Nov 11 10:36:35 CST 2009 (Lihua_68693)
Copyright (C) 2006 Huawei Technologies Co. Ltd.


Boot Address 0xbe000000

Initializing Arena.
Initializing Devices.

@w45260: Flash Manufacture id :c2

@w45260Flash Device id :227a

@w45260flipCFIGeometry:0
Parallel flash device: name MX29LV128DB, id 0x227a, size 16384KB
*** GetHG556aBoardVersion = <0> ***

CPU type 0x2A010: 300MHz, Bus: 133MHz, Ref: 64MHz
Total memory: 67108864 bytes (64MB)

Total memory used by CFE:  0x80401000 - 0x8052A510 (1217808)
Initialized Data:          0x8041F3C0 - 0x80421B60 (10144)
BSS Area:                  0x80421B60 - 0x80428510 (27056)
Local Heap:                0x80428510 - 0x80528510 (1048576)
Stack Area:                0x80528510 - 0x8052A510 (8192)
Text (code) segment:       0x80401000 - 0x8041F3B4 (123828)
Boot area (physical):      0x0052B000 - 0x0056B000
Relocation Factor:         I:00000000 - D:00000000

*** GetHG556aBoardVersion = <0> ***

Board IP address                  : 192.168.1.1
Host IP address                   : 192.168.1.100
Gateway IP address                :
Run from flash/host (f/h)         : f
Default host run file name        : vmlinux
Default host flash file name      : bcm963xx_fs_kernel
Boot delay (0-9 seconds)          : 1
Board Id Name                     : HW556
Psi size in KB                    : 64
Number of MAC Addresses (1-32)    : 10
Base MAC Address                  : 64:16:f0:55:aa:7b
Ethernet PHY Type                 : Internal
Memory size in MB                 : 64
CMT Thread Number                 : 1

*** Press any key to stop auto run (1 seconds) ***
Auto run second count down: 0
boot kernel from be020100
Code Address: 0x80A00000, Entry Address: 0x80a00000


CFE version cfe.d081.5003 for BCM96358 (32bit,SP,BE)
Build Date: Wed Nov 11 10:36:35 CST 2009 (Lihua_68693)
Copyright (C) 2006 Huawei Technologies Co. Ltd.


Boot Address 0xbe000000

Initializing Arena.
Initializing Devices.

@w45260: Flash Manufacture id :c2

@w45260Flash Device id :227a

@w45260flipCFIGeometry:0
Parallel flash device: name MX29LV128DB, id 0x227a, size 16384KB
*** GetHG556aBoardVersion = <0> ***

CPU type 0x2A010: 300MHz, Bus: 133MHz, Ref: 64MHz
Total memory: 67108864 bytes (64MB)

Total memory used by CFE:  0x80401000 - 0x8052A510 (1217808)
Initialized Data:          0x8041F3C0 - 0x80421B60 (10144)
BSS Area:                  0x80421B60 - 0x80428510 (27056)
Local Heap:                0x80428510 - 0x80528510 (1048576)
Stack Area:                0x80528510 - 0x8052A510 (8192)
Text (code) segment:       0x80401000 - 0x8041F3B4 (123828)
Boot area (physical):      0x0052B000 - 0x0056B000
Relocation Factor:         I:00000000 - D:00000000

*** GetHG556aBoardVersion = <0> ***

Board IP address                  : 192.168.1.1
Host IP address                   : 192.168.1.100
Gateway IP address                :
Run from flash/host (f/h)         : f
Default host run file name        : vmlinux
Default host flash file name      : bcm963xx_fs_kernel
Boot delay (0-9 seconds)          : 1
Board Id Name                     : HW556
Psi size in KB                    : 64
Number of MAC Addresses (1-32)    : 10
Base MAC Address                  : 64:16:f0:55:aa:7b
Ethernet PHY Type                 : Internal
Memory size in MB                 : 64
CMT Thread Number                 : 1

*** Press any key to stop auto run (1 seconds) ***
Auto run second count down: 0
boot kernel from be020100
Code Address: 0x80A00000, Entry Address: 0x80a00000
Decompression OK!
Entry at 0x80a00000
Closing network.
Starting program at 0x80a00000
[    0.000000] Linux version 4.14.162 (builder@buildhost) (gcc version 7.5.0 (OpenWrt GCC 7.5.0 r10860-a3ffeb413b)) #0 Mon Jan 6 16:47:09 2020
[    0.000000] Detected Broadcom 0x6358 CPU revision a1
[    0.000000] CPU frequency is 300 MHz
[    0.000000] 64MB of RAM installed
[    0.000000] board_bcm963xx: Boot address 0xbe000000
[    0.000000] board_bcm963xx: CFE version: d081.5003
[    0.000000] bcm63xx_nvram: nvram checksum failed, contents may be invalid (expected 33303436, got 71676413)
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU0 revision is: 0002a010 (Broadcom BMIPS4350)
[    0.000000] board: board name: HW556_A
[    0.000000] MIPS: machine is Huawei EchoLife HG556a (version A)
[    0.000000] Determined physical RAM map:
[    0.000000]  memory: 04000000 @ 00000000 (usable)
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Primary instruction cache 16kB, VIPT, 2-way, linesize 16 bytes.
[    0.000000] Primary data cache 16kB, 2-way, VIPT, cache aliases, linesize 16 bytes
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x0000000000000000-0x0000000003ffffff]
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x0000000000000000-0x0000000003ffffff]
[    0.000000] Initmem setup node 0 [mem 0x0000000000000000-0x0000000003ffffff]
[    0.000000] random: get_random_bytes called from 0x804c6738 with crng_init=0
[    0.000000] Built 1 zonelists, mobility grouping on.  Total pages: 16256
[    0.000000] Kernel command line: rootfstype=squashfs,jffs2 noinitrd console=ttyS0,115200
[    0.000000] PID hash table entries: 256 (order: -2, 1024 bytes)
[    0.000000] Dentry cache hash table entries: 8192 (order: 3, 32768 bytes)
[    0.000000] Inode-cache hash table entries: 4096 (order: 2, 16384 bytes)
[    0.000000] Memory: 58536K/65536K available (4071K kernel code, 197K rwdata, 548K rodata, 1256K init, 209K bss, 7000K reserved, 0K cma-reserved)
[    0.000000] SLUB: HWalign=16, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] NR_IRQS: 256
[    0.000000] clocksource: MIPS: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 12741736309 ns
[    0.000027] sched_clock: 32 bits at 150MHz, resolution 6ns, wraps every 14316557820ns
[    1.033817] random: fast init done
[   53.807871] random: crng init done

Waited for 2 minutes. Nothing else.

Daniel González Cabanelas commented on 13.01.2020 21:53

Looks like this bug is a duplicate of:

 FS#1951   FS#2202 

Project Manager
Baptiste Jonglez commented on 13.01.2020 23:47

Thanks for the logs, indeed it's a duplicate of  FS#2202 

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing